Hub discovery


Just received my Hubitat c7 after years with smartthings and I am having issues setting up the hub. I followed the instructions provided, connected to the LAN and then powered it on. The hub does not get discovered on its own, the only way I have been able to find the hub is via the MAC number. Once I click on connect hub, the page does not load. It says the server is taking to long. I made sure the hub was on the same wifi. I have a fast internet so I do not think that is the issue. Never had problems loading anything. I have tried on safari, and Firefox both on my iPhone and MacBook. Has anyone encountered this issue and have any helpful tips ? Thanks in advance and sorry for the newbie issues.

It sounds like it's not connecting to the internet. Is it on a vlan or being blocked at a firewall?

1 Like

sounds like a job for @bobbyD


First, try to reset the networking settings on the hub by turning the hub over and using the point of a pen press the small button just beneath the surface of the hub casing for at least 10 seconds.

If that doesn't resolve the problem, you may try the following:

  • Use an alternative device to attempt registration (we recommend using a computer for the initial set-up)
  • Use an alternative browser (we recommend Google Chrome for the best experience)
  • Make sure your device is connected to the the same network segment (i.e. same subnet)
  • Reboot your router.
  • Power cycle your hub by shutting it down from Settings, then when the LED on the hub turns red, unplug the power cord from the wall outlet for 30 seconds before plugging it back in.

If you set a static IP on the hub, you probably have put in something invalid. The network reset described above will clear that out and put it back on automatic DHCP.

Also, after the network reset you can try going to http://HUB.IP:8081 to access the diagnostics page. If the LED is green this page should be available (assuming the hub actually got a valid IP config and connected to your network).

I am not computer savvy at all lol. Would not know how to check for a VLAN. I do not think it’s a firewall issue since I am also trying on my iPhone and I am getting the same result as on the computer.

Awesome! Thank you. I will do as suggested as soon as I get home and see if this helps. I will keep you posted if it worked.

I was initially looking into the static IP in the forum, and saw someone mentioned it is good for someone who knows what they are doing. Since I have no clue about any of this I decided not to go that route lol I will learn as I go.

You would rather reserve an ip in your router for the hubitat.


That was me in another post :+1:

1 Like

This worked! :muscle:t2: I did the reset on the hub and once it came back on, I was able to find the hub on the website. Good to go. Thank you all for the fast help.


So you did previously mess with the networking settings and break it somehow..... :upside_down_face: :rofl:

I never messed with the network. I plugged it in and that was it. The only thing I did was reset the back or the hub like was said on here lol

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.