Hub currently thinks it is between sunset and 9:15pm and has thought so since last night at sunset

Last night I noticed my light came on full brightness around 9:05pm when I went into the bathroom like it is supposed to do between sunset and 9:15pm. However when I woke up at about 4 am it still came on at full brightness instead of the 30% it's supposed to so I setup a simple if time between sunset and 9:15pm then and it shows true even now at 8:40am. I had this happen once around a month ago as i had the rule set for sunset to 9pm however then sunset was after 9pm so it made sense now however I don't understand why it thinks it is between sunset (9:04pm) and 9:15pm?

I just rebooted my hub and now it shows false so it should be good again. Just not sure what would have caused that issue.

I have almost the exact same problem as well. Seems to occur every week or so. Similarly when I reboot the hub it fixes itself. Haven't worked out a solution yet.

I've only had it happen twice luckily the second time being about a week ago.

It seems to happen with me every 7 to 10 days. Haven't been able to pinpoint a reason for it. I've reported it to support. But its good to know its not just me.

One fairly common cause is if the hub boots quicker than your router or modem. If the hub is up and running, and it tries to do a time update but can't reach the internet, it will do this.

There is a periodic time setting app available that many seem to like. You might try this and see if it fixes your problem.

1 Like

Thanks I'll check it out.

As a side note, the issue seems to occur after the hub does its 2am backup/maintenance as it is only a minute or two after this that all routines relying on sunset/sunrise go haywire.

I had put in place a routine to run at 2:02am to reboot the hub if it thinks its between sunset and 11pm at that time but the time app may be a better solution.

Cheers.

1 Like

I've been using the NTP device since shortly after it released and in my case anyway when this has happened the time on the device was correct as were the sunset and sunrise times as shown in the first post, it was just that RM was incorrectly evaluating time as both between sunset and 9:15pm and also correctly evaluating the time as between 6 am and sunset, but since my rule has the evening stuff later in the rule it ended setting the evening mode instead of the correct mode as I'm using RM to manage modes instead of mode manager and it has worked correctly every day, evening, and night except 2 now both times it would evaluate times between sunset and any other time as true wether or not it really was true. A reboot has fixed it each time.

With it happening twice 5 months I don't expect them to be able to track it down easily unfortunately.

This also happened on my parents hub once a week or two before I posted the original post about my hub. I keep both hubs at the same firmware revision (this last time it was on 2.2.2.129 when it happened) and theirs had this happen with in a day or two of an update whereas mine was a week or more after that first time.

Download the Hubitat app