Hub crashing and becoming non-responsive

I've been on the latest firmware since release. This morning, nothing was responsive and I couldn't get to the Hub's page. So I went to port 8081 and did a shutdown, pulled the power for several seconds, and then it booted back up.

About an hour ago, I left the house and nothing worked again. I can't get to the page at all. I'm going to do another shutdown, but can someone help me diagnose the issues? No new devices have been added in weeks and the last update I made was the firmware when it was released (over a week or two ago).

When you do get in I'd take a look at the logs for any errors or unusual activity (i.e. device spamming the network with power or temperature reports, etc.).?

Thanks. I'm not exactly sure what to look for in the logs. Is there an easy way to export them to a spreadsheet?

Don't remember ever seeing a log export, but it doesn't take much time to copy and paste the entire log if you want to do that. I generally just scroll down looking for patterns (generally several messages of the same or slighlty varying text, or color coded entries (red - Error, Orange - warnings, light blue - informational, dark blue - debug) - normally less than a 5 minute exercise.

Another thing you can look at is the device and application stats from the logs page to see if something looks abnormally high.

1 Like

It has crashed a third time. Sigh

I looked at the logs and the logs are empty between 4 PM and roughly 6 PM, when I forced a reboot.

Should I restore a backup from yesterday or the day before? I'm assuming it is DB corruption.

It’s worth a shot...

It has been awhile since I did a restore, but I'm at 7 minutes so far and it's still restoring. I thought it was quicker.

That does indeed sound long. I seem to recall the restore taking less time than the following boot-up, but it has also been a while since my last restore...

Still going after 40 minutes. I'll give it an hour as I did see some reports online of a restore taking that long.

I opened the hub interface up in another window and noticed this:

I'm guessing for some reason, it can't contact the hub and is spinning its wheels. Not sure what to do at this stage, as if I click on the Backup and Restore option in the new window, it goes back to the "Backup-Restore is currently Running" page.

Yea, it didn’t work properly.

My approach would be to connect to :8081 and do a reboot.

Have you tried restoring from a downloaded file? That would be the recommended approach in this case.


I'll try that next. I did download the previous two backups so I should be able to do that pretty easily.

1 Like

That seemed to work fine. Let's see if it is more stable now.


So far, no more crashes since restoring a previous DB.


I am having this same problem. I was going to order a new hub but i may have to wait til i get home and try your method. it wouldnt restore the recent db.

Yeah, just download a copy locally to your computer and then restore from that. It only took maybe 2 minutes and the hub has been solid ever since.