Hub Connecting With HE Server

Hadn't had a need to access my hub remotely in some time. Today I was waiting for the wife at the docs and thought I would check things out. Opened the new app, IOS, wouldn't connect to my main C8 hub. Changed to my aux C5 hub. Same result. Downloaded the old app. Same problem. Opened a browser went to, logged in. Selected remote admin. No connection. Tried remote admin to a friends hub and it went right thru.

I know my internet was up as my Homekit was still working fine. Also had access to my cameras which were not affiliated with HE.

I had accessed the hub earlier in the day while at home so it was up and running as it should.

I had put some wifi outlets on both hubs for a different access. Did a power down on my C5, which doesn't have much going on and if it got corrupted it wouldn't be that big a deal. When it came back up I was able to access it with no problem. In the C5 I have a rule to reboot the C8. So I re-booted the C8. I then had remote access to that one also.

So my point to all this. WHY?? Is there some time frame for the hub to notify HE server it's there? Is there some way to know it's not there?

It seems that things just want to quit working and require a reboot and no way to know until it quits. Just like when Homekit quits working it takes a reboot. If I had something important to do and didn't have the wifi plugs I would have been screwed.