Hub became non-responsive and unreachable, no function in light switches

Hi all,
I just had my first legit non-initial-setup issue with my Hubitat that I'm trying to understand, and which also brought up another question as well. I'm on a C-8 and was running (now on, after I got this current issue resolved).

I had to hard reset my modem and router, and while it was down/rebooting I noticed that my light switches did not work, I couldn't turn on or off any of my lights. When I tried to load up the Hubitat app it could not find anything (though that isn't surprising since on the phone it's outside network -> home network and no modem/router) but then when I went and got on the computer that was then connected to the router (regardless of whatever the modem boot status was) I still was not able to connect to the hub, not through the IP address, or through hubitat.local as some on here had suggested for related issues, not through any means could I access it, and even with the modem/router both back up and running and computer with active wifi/internet I still could not access the hub and the switches did not work. No power was ever lost by the hub itself or anywhere in the home, just the modem/router were unplugged. Without being able to login to the hub to see what I could diagnose, I had no choice but to just unplug the Hubitat and plug it back in. After some time it came back online and slowly switches started working again.

First question is why the hub would have even shat itself in the first place when it was never touched. Why I wouldn't be able to login to it upon modem/router reboot, etc. I went in to the router settings and confirmed that I did have a static/dedicated IP address for the hub, but that leads to my second set of questions...
I thought the whole point (or at least a significant portion) of Z-wave etc. was so that it was strictly local (ie, not just not going through the cloud, but not even needing the router itself, just the hub). Why did I lose light switch function just because the modem/router were being rebooted?
As I mentioned, an unplug/replug and forced reboot eventually worked, and I updated from to, but I'm trying to understand what just happened so that I can prevent issues if the internet goes down or my modem or router go bad or some other completely non-C8-related issue occurs and I lose the ability to turn my lights on or off.

Any input is greatly appreciated. Thank you!