HSM not disarming after 2.2.6

When I went to disarm HSM this AM after updating to 2.2.6 yesterday, it would not disarm, even though both the Dashboard and HomeKit showed disarmed. Here was an error in the logs:

java.lang.NullPointerException: null on line 304 (appArmHandler)

Any ideas, or approaches I could take to resolve?

maybe it doesnt know it is armed.. have you tried arming agian.. then disarm?

What worked was to go into RM, open the “Disarm” rule (RM 4.0), then select “update”. Whatever.... :slightly_frowning_face:

1 Like

I've had the same problem a couple times now, with the same error. I don't have a disarm rule, I was disarming from the HSM panel within a dashboard. So I don't understand what to update? Any advice is greatly appreciated.

Thanks.
Jason

I just experienced this issue again (exact log error again). Reloading the external rule was a “red herring”. I am planning to open a support ticket regarding this.

Thanks for the update. I emailed support last week but haven't heard back yet. Sounds like an ongoing issue.

Could you please provide more details. Support can't help you with this.

I need to see the setup page for HSM to start, and please confirm that this error is the one reported above for line 304.

Also, what exactly is the action you take to attempt to disarm it, that causes the error.

Thanks for the reply - did not expect a reply here, much appreciated! This has happened to me on March 25, then just a few days ago (April 21-ish).

Disarm action is via Homebridge (version 2.5.3), but the Dashboard also indicated "disarmed", when it was not.

Log indicates app 1 (HSM) is disarmed, then immediately follows with the error message, then all other actions (notifications, etc) fire off correctly. Every other time (disarm happens usually once a day) has operated as expected.

HSM config screenshots:


Every HSM action is logged, and events are tracked in the System Events that you can view from the top level menu. So that's the place to start. I really need to see a screenshot of the logs where the event is thrown, showing the entire line (not copy/paste). Unfortunately, the error you showed makes absolutely no sense.

It would be most helpful if you can find a reliable way to reproduce the failure. But, lacking that, these basics are needed for me to understand what is going on. For example, can you arm/disarm HSM from its user interface? If you have a RM rule involved, please show that.

Here is the System Events and Log screenshots. All my rules are just notifications for "sounders", that are triggered by HSM events.


Your screenshot of HSM page didn't show everything. Does it show that it's armed or disarmed? Refresh the page first. At the top of the page, in the black top border, does it say armed?

Yes - see updated screenshot above

Not seeing it. Just answer the question please.

Sorry, which question is that?

Does HSM setup page show that it is disarmed or armed? Are you able to arm/disarm from that page without an error?

I understand - currently it is disarmed (see screenshot), but we are discussing an issue in the past, so I was confused.

I need to isolate the cause of the error. Can you arm/disarm it from the UI without an error?

Yes. For about 30 days it seems, then it throws an error. So I can’t reproduce this, I just wait for it to happen. I am now auto-rebooting hub every week to see if it is one of those “Java runs out of resources” kind of things, since I have no idea what happens at line 304…. I thought maybe someone might know.

This is not really a thing. Software pretty much does the same thing in the same context every time.

When that error was thrown, did anything untoward happen besides the error in the logs? It appears from your logs that HSM was in fact disarmed.

There is nothing at line 304 that would throw that error, assuming you are on 2.2.6.140. My suggestion is that you download a backup your hub database, do a Soft Reset of your hub, and restore that database. I'm guessing you have some corruption in your database, but there is really nothing specific to go on.

Nothing different from any other Pandemic Day of disarming, then entering an outbuilding. No other errors, nothing unique, nada. HSM says it is disarmed, yet behaves as armed.
And I am on latest version.

Download the Hubitat app