HSM Night Alarm Cannot Select Sensors


Is it normal to not be able to select individual contact/motion sensors in the Night setting? I can do it for "away" but not the night. Thank you in advance

You should not be choosing the switch to use all of your sensors. It is a known bug. If you've turned that switch on anywhere within HSM, please go back and turn it off and choose your devices for each setting individually.
I'm not sure why it's not giving you an option to choose sensors. I would go back to the main apps page and start over. with it. But that's just what I would do. Seems something didn't configure correctly.

1 Like

I don't have a issue with mine, so maybe you have done something different in your setup? I would take @april.brandt advice and start again to see if it happens again.

The solution is to not have any other configuration with "All contact sensor".

I had armed-home with "all contact sensor". I removed that option, selected manually. Saved. Then, I went back to that screen and I was able to select individually.

I'm glad it is fixed, but it is definitely a bug in my opinion.

Thank you all for the inputs! :slight_smile:


I don't use this as I have contacts for switches so would explain why you see it. Have you tried to replicate it again?
If so I'm sure it's something that @bravenel would like to know so he can rectify it :+1:.