HSM Arming Home Instead of Armed NIght

I found odd behavior of HSM switching to arm-home where it should go to arm-night.

The configuration shoes ambiguous entries:

and how it should be:

According the documentation it should have a drop-down for Arm-Home?

I bypassed this problem with and rule setting explicitly to arm-night after mode changed to night modus.

Has anyone the same problem / solution?

Thanks, and regards!

Found it: you need to define what to do for arm-home to get the drop-down displayed where you can de-select the modes. If the configuration is removed again, also the drop-down dis-appears.
Hmm, not straight forward.

Download the Hubitat app