HS WD-200+ Dashboard Tile?

I'm very new to HE (previously was on ST). Just to start out, I moved over just 2 light switches, a GE dimmer (12724), and a Homeseer WD-200+. Took a while but finally got them both included.

I created a very simple dashboard adding both devices as dimmers. The GE one works fine. The tile for the WD-200+ does nothing. It doesn't get the correct state of the device (always starts off as ON even if the switch is OFF). When I tap on it to toggle the light it just shows an hour glass. Dimmer slider does nothing. When I refresh the page it says the light is ON even if it's not.

Do I have to do anything special to get the WD-200+ working with a Dashboard Tile?

My 2 devices are physically arranged as follows, HE hub in the same room as the GE switch about 10-12 feet away. Then the WD-200+ is down the hall in another room about 15 feet away from the GE switch. Is it possible the physical setup has too weak of a connection to the WD-200+? Is there a way to test that?

The dashboard tiles are only mere representation of your device status page. If the device isn't responding on the dashboard tile, it's a very high likely hood that when you open the device's edit page the status does not operate there either.

The problem for the device not updating in that device page can be a multitude of possibilities (incompatible driver, insufficient mesh not providing communication to device, etc)

try codahq's custom driver for the 200. Works fine on my dashboards.

If the switch doesn't behave with my driver either it probably didn't make it all the way through inclusion. If that's the case you might try to exclude it and include it again (despite it being sort of a pain it sounded like). By the way, if including a switch is especially painful it might be a good indicator that the signal isn't great between the switch and the hub. This can be for more reasons than just distance. You might have some other interference stepping on it. Good luck.

Thanks codahq! The man himself! I am using your driver now, works great. I think the problem was the signal, I rebuilt my Z-wave mesh moving from the hub out and things seem to be working a little better.

I did notice that while my Dimmer Tile works now, when I use the slider to adjust the level, it will appropriately change the light, but the slider on the tile will revert back to the previous level.

For example:

If the slider is currently at 99% and the light is on at 99%, I drag it down to 50%. The light will dim to 50%, but the slider will bounce back up to 99%? Is there a fix for this or am I doing something wrong? Even if I close and re-open the dashboard, it still shows 99% even if the actual light is only at 50%.

You found a bug. I think all of my dimmers are set to 0 ramp rate and I primarily use just on/off so I didn't catch this one. In setLevel there was still the SmartThings way of adding delays between commands. I fixed it and also made some other small changes. The easiest way to update is from from the device driver using the "Import" button and then click the "Save" button.

Download the Hubitat app