How to reset a hub

I received my hub yesterday and migrated my thermostat and a homeseer sensor to it, no problem. I attempted to exclude and include a zwave bulb. It excluded, but the inclusion process failed. The themostat and sensor then disappeared from my zwave network in hubitat. So I excluded and included them again, and did a zwave repair.

I then linked the hub to Alexa and established some thermostat change settings. 9 PM turn thermostat to 62, 6 AM turn it to 68. Last nights thermostat change worked as expected. And Alexa was responsive.

This morning I got up and it felt cold so I asked Alexa for the temperatures on the sensor and thermostat - no response.

I got up, the thermostat did not change to 68 at 6 this morning. I webbed into the hub and I got a corrupt database message. I followed the instructions for a soft boot getting the mac address as a password from my router. I get to the soft reset page, type in soft reset and hit the soft reset button and nothing happens - waited quite a while, backed out, tried the reboot command. Nothing. Waited 2 hours still nothing and ended up unplugging the hub and plugging it back in. Now I can find the hub but can not connect.

I have contacted support, they have not yet gotten back, but I understand they have a small staff so it may take awhile. Suggestions? I had cleared this morning to more some of my zwave stuff over. On the positive side I did like the dashboard, it is easier than homeseer.

Related question is are generic zwave bulbs not supported?

thanks,

At the bottom of the ZWave Details page is:

WARNING: It does what it says it does. The internal ZWave controller will forget everything. You will have to start over, I'd suggest going the Soft Reset route and NOT add in a saved backup. That gets the hub to match the ZWave Controller (radio) as Empty.

It pretty much puts you back to yesterday, 10 mins after you opened the box. :slight_smile: The hub is registered, it has a name and a location, not much else.

It's rare that this advice is offered but in this case, you probably have enough ghosts with no easy way to clear them that starting over might actually save time.

3 Likes

OK I now know what is happening but not why. I got the sensor and thermostat added back. I went to add a schlage lock. I put the lock in exclusion mode, I arrowed down a bit and saw the warning, not exact works, excluded the kitchen sensor which was not in exclusion mode. It seems like if it can not find a device in exclusion mode, it excludes an existing device on the . That would explain why the devices disappeared on me yesterday. But I am not understanding why it would do this. It looks like I need to use homeseer to exclude before I can include on hubitat. I can not use hubitat to exclude devices on another network.

Exclusion isn't expected to work like that...

The Controller (this hub, that hub, any hub) goes into Exclusion and sits there waiting for a sign from a Device. Devices have to send "yoohoo, me.. Pick Me!"

The only device in the vicinity to be sending that is expected to be the device that wants to be Excluded. That's why the Include or Exclude "dance" the manufacturers define are sometimes quite complicated. They don't want an accidental Exclude because they know that Excludes occur all the time.

I know my GE/Jasco switches/dimmers/fan controllers all use a single push to enter Include/Exclude BUT it's a physical push. If I put a Controller into exclude, and NOT push the paddle of those GE/Jasco devices, they never get excluded. However, imagine I'm adding a new device, I go into exclude and the kids upstairs press a paddle on a GE/Jasco. That's the device that got excluded. Again, this leads to many manufacturers creating a non-simple sequence to go into Include/Exclude. (Click 3 times, etc.) On the other hand, my 12 Aeon Multisensor 6's also have a single click to enter Include/Exclude but that hidden, internal button is never accidentally or coincidentally pushed. It's a great example of a simple "dance."

3 Likes

Unfortunately, it happened to me again when I attempted exclude again My kitchen sensor deleted itself from the network even though it is not in exclusion mode. and three rooms away. I will just use homeseer for exclusions, not really a problem. I am bit more concerned that I can not get any of my generic zwave bulbs to connect to the hub. I have a mixture of manufacturers, they are all zwave plus certified. I will need to replace them with zigbee bulbs, unfortunate because I like the zwave mesh network, it is has been very reliable. My switches connect fine. I am moving off homeseer because I do not like the design of homeseer 4, I like the hubitat design much better so far.

I've shied away from smart bulbs as much as possible. I have 3 from two manufacturers, Aeon and Domitech. Pretty sure neither of the models I use are available any longer.

However, they've been great as far as Zwave Mesh Participants. :slight_smile: I use them as CT bulbs 90% of the time but also use their RGB to act as alerts. (Garage door open = purple, etc.)

I can't offer any bulb specific device is what I'm saying I think.

My assumptions are: You have a C-7 Hubitat hub and it's on the 2.2.x set of Platform software.

I wouldn't want you to have more devices drop but if it were my hub doing this, I'd put it into Exclusion from this menu:

And just let it sit. Don't actually attempt to exclude anything and then verify after the 30 seconds expire, that nothing got excluded and no "unknown device excluded" message appears on that screen.

In other words, I'd try to get confidence in the basic functionality. If you DO get an exclude, then I'd lean towards it being a defective ZRadio and escalate with Support.

1 Like

Strange that sensor deletes itself. What brand and model? If you factory reset a device you don't have to exclude it first. As far as your schlage lock goes, pair that within 3 feet of the hub for reliability. Use a beaming repeater as close to the lock as you can get it (a Ring extender 2 is a great model) After all that you've been doing, go to your z-wave settings page and check for ghosts... If you have any these will cause a lot of issues.

2 Likes

It is a homeseer 200 multi sensor.

In pairing the door lock, I physically removed it and was about 6 inches away from the hub. I has been a long time, but if I remember correctly it took a few tries when I originally paired it with homeseer. The hub lives 10 ft away from my front door, so I am unlikely to get any repeater closer than that.

I think many of the problems are because of the phantom devices zwave created. I decided to start over and am adding devices one by one and checking the zwave network with each add and it is going better. Part of my problem was my own fault (sort of). The bulb's inclusion instructions states to rapidly turn the bulbs off and on 4 times. But I discovered this was confusing the network and turning them on put them in inclusion mode.

Thanks.

1 Like

Normally you shouldn't reset, you can just remove the ghosts. But yeah, anytime you have a failed pairing check for a ghost

1 Like

Download the Hubitat app