How to get mesh-repeat to work?

I've got hubitat C7 and mix of z-wave and zigbee devices.

I have an Aeontec Z-wave Plug for my Airconditioner unit in the master's room, and the MESH for that device is enabled.

I've got a z-wave door sensor roughly 3 meters away from that Aeontec PLug and it's not working!

If i bring that door sensor in another room nearer Hubitat then it works. I understand that the master's room is a bit far from the hub and I would understand if the Door sensor can't reach the hub from there. But the fact that I have a z-wave repeater (Aeontec Hub) beside it that works flawlessly for weeks, makes me wonder why the Door Sensor isn't getting thru.

I've rebooted all devices including the plug but no improvement

I even set the MESH feature on the plug OFF and ON again just to make sure.

Is there any other way i can check if MESH is actually enabled on this darn thing?

How else can I troubleshoot this?

Looks like you’re mixing your meshes…. Range extenders will extend the zwave (or zigbee) mesh of the hub they are paired to, but turning on Hub Mesh for them doesn’t permit them to extend the signal to another hub’s mesh - only let’s the remote hub see the attributes.

As strange as it sounds, sometimes the repeater is too close to the device you want to use it, and you may need to move the extender closer to the hub. My most used extenders seem to be about 1/3 the distance from the hub and 2/3 the distance from the device using them. Like anything though, YMMV.

If you move the repeater, you could try doing a Zwave repair on the repeater, and then one on the device. Won’t guarantee that the route will switch over, but will at least refresh the neighbors table. Note that it still may be days or weeks before the extender gets used though.


im slightly confused but as I understood it I should turn off the HUB MESH feature? And the mesh/repeater enabled devices will simply repeat signals automatically on their own (no settings needed)? that's just mad confusing

Also, my repeater (aeotec plug) is plugged at my Aircon's power source and the door sensor is at the baclony's door... these are FIXED POSITIONS so I don't know how im going to relocate these devices. How does one resolve this then? Shall i add another repeater somewhere?

Mains powered devices will act as repeaters without changing any settings. I thought you were talking about onf these earlier:

So yes, it sounds like you may need another repeater or 2. You could use the Aoetec above or my preference:

well since im using Aeotec Plug

which should act as a repeater, and that my door sensor is right beside it (2-3m), why am i able to control the plug (hub to plug has range) but the door sensor is out of range .

C7 HUB ----------------> Aeotec Plug (acting as repeater) -----(2m)---> Door Sensor

Are you saying I have to add a dedicated repeater in between hub and door sensor? Isn't that what the plug is supposed to be doing already?

Can you post a screenshot(s) of your Z-Wave Devices page? Sometimes, there are devices that haven’t been paired properly (commonly called “Ghosts”) and these can cause issues with the Z-Wave mesh. There are a lot of people in the community that can help diagnose and fix those issues.

The ZigBee and Z-Wave protocols use a mesh architecture unlike Ethernet (Wi-Fi) that is architected like a star with a central hub. Your Hubitat hub has 'master' ZigBee and Z-Wave radios that are the center of each mesh. The mesh is automatically created by the devices themselves. Devices not relying on batteries will act as repeating nodes for their respective networks.

The switch on the device screen labeled 'Hub Mesh' is confusing, it's only used if you have two or more Hubitat hubs.

Your hub allows you to control devices on three different wireless networks, Wi-Fi, ZigBee, and Z-Wave.

I hope that clears thing up for you.


These are all my zwave devices atm. I don't think I have any GHOSTS but I do have a few devices that are currently offline.

I do look forward to the community's help (and patience)! :slight_smile:

Thanks man.
one thing that's unclear, if i have one Hub only, should I turn off this setting on all devices? or does it not matter whether it's on or off - with regards to my current issue?

Three ghosts: 0x09, 0x0D, 0x10. Would also recommend you pair the Aeotec Siren 5 without S0 security (i.e. with security = None). Ideally you'd do the same with the Fibaro keyfob.

Also, topology isn't great. It indicated limited paths to most of your devices.

1 Like

wow ok so those are the ghosts... i'll remove these ghost devices then.

Can I re-pair the Siren and Fibaro Keyfob without SO once I have made this current issue work? Cause the latter devices aren't deployed permanently yet (just experimentation)

Topology limited - similar to above, most devices are actually on experimentation phase. Once I get this current issue resolved (and prove mesh / repeating is working) then i can finally move forward to deploying all other devices properly with repeating devices in between them

For reliability S0 security should be avoided at all cost. Your ghost devices will also cause reliability issues. How many of these devices are repeaters. Generally speaking that means not depending on batteries. Something to remeber is not all repeaters are created equally. Some can only repeat a limited number of devices while others can do allot more. The more repeaters the better.

That image you created with the blue and red squares. You want as much of that to be blue if possible. It is nearly impossible for it all to be blue if you have battery powered devices, but you want to see allot of it blue. That just means you have allot of options for routing for tour mesh to be more reliable. I would also suggest you tey to stick with zwave 700 gear at this point. Seems they just have better range and signal strength.

1 Like

You may also want to load the Hubitat Z-wave Mesh Details app. It can provide some good insite as well.

tnx mate. I am trying to learn/understand this z-wave topology report actually. it's quite confusing i wish someone made a video orientation so it's easier to understand.

YES, I would love to go Z-wave 700 all the way but the options (atleast the affordable ones) are quite limited for now.

Thank you

So i removed all the ghosts and rebooted everything.. Im still getting this

1B is the Aeotec Plug (aka mesh repeater)
1C is the door sensor

I honestly still don't understand what this means as it's really confusing but it's clear that 1B is not doing too well (both axis in RED) ...... but it's actually connected and controllable from the hub

thanks for pointing me towards this, i've installed it and found it so enlightening!

First, the Topology Map data it's based on is not "live" -- it's updated only occasionally. Therefore, the map shouldn't be used as if you could move things around and see the results on the map.

To understand it better though, one axis is from the Hub's point of view and the other axis is from the Device's point of view.

Take your Aeotec Plug, 0x1B, it is not seen by the hub, and is not able to see the hub. Symmetrical, cool. :slight_smile: Let's look at 0x0B which has 3 blue blocks horizontally and 7 blocks vertically. Hmm, not so symmetrical. It has only one repeater in common: 0x13, yet the ZWave Details show it Direct connect.

For 0x1C, your door sensor, the ZWave Detals page shows it as a direct connect and has a decent RSSI and an excellent RTT. Which proves the point that the map data is not as up-to-date.


You want to be sure that all mains powered devices that have been paired to the hub are turned on. Otherwise, they will cause issues as other devices will try to route through them. It is better to unpair them if you are going to turn them off.

The mesh also tends to settle down and work better with time. This makes it difficult to experiment…

1 Like

very good to know. Thanks mate.

1 Like

I don't think it matters, but I'd turn them off since that's the default state.