How to get a device back into Hubitat?

I have an Inovelli Fan+Light that physically works, but has dropped off Hubitat. (By that I mean the route is blank and turning the fan and/or light on/off doesn't show up in the logs).

I tried to repair the device but it said it wasn't found. I then tried to refresh it, but it just says it is pending. (See screen shots below).

I have just turned the light/fan on/off on Oct 13, 2021 but it shows the last activity was on Oct 4.

How can I get this back into Hubitat?

Thanks,

Route Missing:

As seen from the Devices page:

Current status:

I might try something easy like "rebooting" the switch first to see if that helps (pull the air gap for a few seconds of more, then push it back in). Moving the hub nearer could be something you try temporarily, and if that helps, ensuring you have a repeater in range may be a good long-term solution. Might not be that easy of a fix, but probably worth trying at least the former first.

Otherwise, it looks like you might be stuck having to re-pair it. To do that, you'll first have to factory reset the switch or do an exclusion. If you opt for that, it may be easier to do the exclusion with another hub or controller, since doing it from this hub will also delete the device and can affect apps (including Rules) that use the device (though if you don't have any or can re-do everything on your own after, either way is fine).

Instead of the re-pair, you can also try a Replace. You'll still have to make sure the switch is factory reset or excluded (and this time, you definitely can't use the same hub), and you'll need the "Replace" button to show in Z-Wave Details (might already be there, or if you refresh once or twice after the reset or whatnot, that may be enough). I've had much better luck with the regular inclusion process, but this should theoretically work, and it won't disrupt any apps on the Hubitat side since it will treat it like the same device. So, if it works, it may be easier in the end

1 Like

I pulled the air gap out and after I pushed it back in I was able to try to repair it.

When I did the repair it said it was successful:
Screen Shot 2021-10-13 at 10.07.21 AM

One bit of strangeness was that even refreshing the page in Safari (which is where I did the repair) did not show it was back (that first screen shot in this reply was after the repair and refreshing the page). I also tried closing the tab and reopening it in Safari with the same result. However, when I closed Safari and then went to the Z-Wave Details page in Chrome it showed it was back. Curiouser and curiouser. But, it not only seems to be working now, but it seems to be making even a better connection as it is connecting with zero hops.

1 Like

Just remember that a REPLACE is the same as an Include, in fact, it is just an Include with the node number being the old number instead of "next."

Like an Include the physical device must be ready to be Included. As @bertabcd1234 said, you need to use something OTHER than the primary hub to perform the exclude. I'm good at doing a Replace because I have 4 hubs and several Z-Sticks. Any of which will perform the exclude.

1 Like

Thank you for the help. Luckily for me, pulling the air gap and doing a repair worked because I only have the one hub.

You didn't come FROM some other Hub? SmartThings, Wink, Vera, etc ? Any/All will do the Exclude deed. :slight_smile:

1 Like

I have one of these and the same thing happened. I found only one way to fix the problem. I brought my Hubitat really close to the device. Excluded it and then included it. I also placed the hub as close to it as I could. I always run "Z-wave repair" after adding or removing any z-wave devices.

This did solved the problem.

If these devices do not include properly then they just do funny things. You can tell if they are including properly by simply changing the on off colors and if they do not change then the switch is not added properly. You need to exclude and include with Hubitat Hub very close by.

The C7 is my first and only hub ever.

1 Like

Luckily, it looks like pulling the air gap did it.

But, I'm concerned about how often the advice is to move the hub really close to the device.

  1. Doesn't the hub need to be connected to my modem when I do that? If so, I physically can't do that for several rooms as they don't all have a cable outlet from the wall.

  2. I thought that it could be bad for the routing if the switch and hub weren't the same physical distance apart.

This advice is due to the fact that many zwave devices go into "whisper" mode (lower power to minimize the broadcast range of the key exchange) when put into pairing mode.

2 Likes

Try changing the colors for a test. If you can do that without issue you are properly added if not excluded and add it again.

I've never really changed colors before, but see where to do it. When I first go into the switch the color is set to "default". If I change it, I don't see a choice for "default". What is the default color to set it back to once I set it, blue?

Change it to Red and if it changes then the switch is connected well if it does not then exclude and include it with the Hubitat close. Once you have control you can turn it back to blue.

Download the Hubitat app