How to factory reset C-4?


I have a C-4 today I received notification of new update version, I ran the update but now when I try to access the hub I get "Problem loading page, Unable to connect" message, I want to factory reset but can't find any button or pin hole.

The C-4 doesn't have anything physical for this, and on the newer models that do, it's only a network reset (so you can get to the thing I'm about to mention if you changed something that prevents your access that way).

To reset the hub, you'll need to access the Diagnostic Tool. This runs on port 8081 at your regular hub IP. See here for more information: Hubitat Diagnostic Tool | Hubitat Documentation. There is a section in the document also describing what you want, though the bulk is done via the soft reset.

I also suspect you might not need any of that. Have you verified that it's not just something simple, like your hub IP address having changed? Use to scan your network, or check your router's admin interface for connected devices (a feature most offer) to be sure if you haven't already. Your problem sounds a lot like that could be it.


Thank you for the reply.

I tried on basic mode it couldn't find the Hubitat.

On Advanced Discovery using MAC address was able to find the Hubitat, same IP as before.

However when I click on Connect to Hub it still shows "Problem loading page, Unable to connect" message

I even tried :8081 same result, tried Chrome and Edge browser too.

I have unplugged power and re-plugged multiple times, left the power unplugged for few hours same result.

I am no engineer and I don't have any knowledge of designing hardware or software, I am only an end user, to me it is surprising the device doesn't have factory reset button, based on your reply even the newer models don't have factory reset option, this is strange how are we suppose to revert changes when things break like my issue.

If none of those work, it is possible your hub is just broken. (Not to tell you the worst possible news first or to say it for sure is; just a possibility.)

I doubt the platform update caused the problem--likely just coincidental. A C-4 hub would be about 5 years old at this point, and some things could go wrong during that time. A physical button would not change that (but, again, does help with the one possible change that you could make on newer models that might lock you out from the actual way to do this; it's not possible to lock yourself out of the hub from network settings on older models since there is no manual configuration of them, by the way, and hence no need for this button).

I tested this update on a C-3 and C-4 and know a few others did, too. One problem (at least) was discovered and fixed for these models, but even it never caused this issue.

If it's not totally broken, the Diagnostic Tool should be available. I'd make extra-sure it's not accessible. For example, make sure you aren't using HTTPS and maybe try a different browser or device. Also see if you router has an admin interface that shows connected devices and their IP address in case the discovery tool is wrong for some reason, though it shouldn't be if it shows up from a scan.

Others, perhaps even the support team (even thought it's well out of warranty by now :smiley: ), may have other ideas.


Factory resetting the hub wouldn't help with network issues. Does the hub have a static IP or reserved IP? If it does, let the DHCP server assign a new IP address. Are any rules or mesh devices working, despite not being able to access the hub?