How to eliminate double chime

I have a rule that plays a sound when a door contact open.

My problem is that sometimes it triggers more than once the chime sound.


Is there a way to only allow a rule to be executed only once when trigged?

try changing trigger door from open to change
and to the If action add "and door open"

should have an "end if" at the end of the rule

1 Like

Thank you for the quick answer. I believe it solved my issue.

1 Like

I don't understand what doing that does. The rule should have worked the way it was before. Now you are just going to have another triggering of the rule that won't actually execute any actions. But what does having that extra execution actually accomplish?

The rule should have worked with the simple addition of the end-if. Also, you could have just had the volume part inside the conditional clause and have the chime sound after the end-if in the rule. That way, if you're worried, you only have that action once.

There was nothing (strictly speaking) wrong with your rule. As you say, it is/was working, except occasionally you received a double chime sound.

You need to take a look at the events being generated by the TRIGGER device (subject to correction, contact sensors in this case?). I am positive you will find the occasional double event for the same action being generated, and your rule is simply responding to it. If you search this forum you will find numerous comments relating to this, and contact sensors are major culprits. You will more than likely find that the events are generated a few hundred milliseconds apart... How to stop this is of course a different matter! Typically it has involved an updated driver of some kind.

Maybe this will solve your issues. (If this is what is happening of course).

There is an app listed at around post 44 that may help.

There is an app for that.. :grin:

Cool but I noticed the double notification also for the Zooz 4-in-1 motion sensor.

[dev:24]( 03:15:31.312 pm [info]( Room Motion Sensor: motion is inactive

[dev:24]( 03:15:31.158 pm [info]( Room Motion Sensor: motion is inactive

I am pretty new to this world of automation, I am not sure why the debounce is not integrated since it looks that most sensors so far are making many requests per action.

With the code I posted above, the issue was greatly reduced for the contact door. However, now I have the issue with the motion which make sometime my light flicks like if it was doing open-close-open very quickly, but not always. I am still investigating that case.

The ZSE40 sends both a notification and a basic set report when motion is detected but you can suppress one of them using the advanced setting in your device view in the Hubitat dashboard. That should solve any issues caused by multiple events being created at the same time. Hope that helps!

1 Like