How to add my Android phone to C8 in the new UI?

Hi - I have been having issues getting notifications on my Android phone with my C8, so I decided to delete my phone's Mobile App Device, uninstall/resinstall the app, and then recreate a new device for my phone.

Unfortunately, I have not been able to figure out how to re-add my phone to my hub. When I select "Add a Device", I don't see a Mobile App Device, Phone, or anything else as an available device related to a cell phone in the list of options.

I saw Mobile App Device listed as a Virtual device, but my understanding is that Virtual devices are only for test purposes.

The app will create the device automatically. I forget what the screen looks like on Android, but you need to log out of or re-select your hub in the app settings. Then it will ask you to pick a device and from there you can tell the app to create a new one.

If you REALLY want to create it manually, then yes you make a virtual device with the driver you mentioned. Virtual devices can be used for testing and also have MANY other purposes.

I didn't see any option to add my phone during the initial setup.

I uninstalled / reinstalled the Hubitat app again. When I try to login for the first time to my Elevation account, the phone is stuck on the "Fetching User Data" pop-up. However, when I closed the Hubitat app and re-opened it again, the Hubitat app went through the initial orientation and setup. But, it never prompted me to add my phone as a device. Maybe I am missing something here.

If I add a virtual "Mobile App Device", how do I tie that virtual device to my cell phone?

When you log into your account from the mobile app it should ask you to select your hub, and then your device from a list of existing Mobile devices on that hub (or create a new one).

I'm probably missing something obvious. I'll show you some screenshots.

This is what I see under the Settings tab on the Android mobile app:

On the Settings tab, it kind of looks like my Samsung SM-S908E phone might be associated to my Hubitat C-8.

However, on the Hub's Devices webpage, I see this:

Now, I can press the + Add device button, but once I try to find any kind of device like a cell phone, the search comes up empty.

I still haven't found any way to add my phone back to my hub. Again, I'm probably missing something totally obvious, but any help here is appreciated.

Tap the hub name, select your hub, then select a device to attach the app to.
I just remembered I had an Android tablet for my dev hub, and just tested it myself.


Thanks, Jeff... I tried your suggestion, and it led to another frustrating - or possibly the root cause - issue.

While my C-8 is accessible on my LAN because I have assigned it a static IP address, it is almost never visible on my router's "Connected Devices" page.

When I tapped on the Hubitat C-8 as you suggested, this is what I see in the Android app:

I have not been able to make the C-8 "available" yet after hours of trying. My C-8 is connected to my router via an Ethernet cable, and it always "disappears" a day or two from the Connected Devices list after I reset the hub.

I am now suspecting this is also the reason why I stop getting notifications on my cell phone after a few days (the original reason why I deleted my phone from the hub in the first place).

I expect that I may be able to connect my phone to the C-8 if I pull the power cord to reset the hub. However, I am holding off on doing that in case somebody from Hubitat wants any diagnostic information from my hub while it is still "invisible".

Do you have any custom network settings on the hub? Is the static IP on the hub or the router side in DHCP?
Have you tried doing a network reset (hold hidden button on hub for 7 seconds, pic in docs). This will clear any network configs and set it back to DHCP defaults.

DHCP would be recommended to avoid any static IP config issues causing a problem.

Do you have any firewall / VLANs that might restrict access?

I have reset the hub a few times with the "Where's Waldo for Adults" reset button when I was trying to figure out why my hub kept disappearing from my LAN.

I did set up the hub with a static IP address with the Network config page, since I needed a specific IP address while I was going through the setup and wanted to get to it when it always disappeared.

I will hand the IP assignment over to the router's DHCP server (I was thinking about doing that as the next step also), and see what happens.

I don't have an firewall rules that will block access, and the hub is always visible for a day or so before it isn't.

I would have thought it would be a firmware failure related to the typical router IP address lease period of 24 hours, except for the static address assignment being on the hub's side.

Maybe the hub isn't periodically broadcasting its address back to the router properly?

Oops. I'm already ahead of myself, apparently.

I had already configured my C-8 to get it's static address via the router's DHCP server.

So the hub disappears from the LAN (even though it is still connected at the static IP address) regardless of whether it is assigned by the hub or assigned by the router.

My totally inexperienced suspicion is that the hub firmware is not properly responding to router ARP commands, and the ARP table entry for the hub is expiring.

P. S.: After I reset the hub, it became available again (for now) on the Android app. I was then able to add the phone as a device on the C-8 by following your directions.

P. P. S.: It probably would be a good idea if these "Mobile Device" steps were added to the Hubitat's "Add a Device" online documention page.

Since I have never heard of this problem on here before with thousands of users, I would suspect it is some sort of issue with the router or network configuration.

When you said you reset the hub, you mean the network reset, or just a reboot?

Double check your routers DHCP reservations, make sure you do not have two entries with the same IP, or multiple different entries for the Hub. Some routers may not even allow it, but some might.

I did a full network reset a few times on the C-8. I know that it worked, because I lost my previous static configuration for my network and had to reconfigure the network again.

I looked at my list of static IP devices, and there are no duplicated entries with the same IP address. The router app probably would prevent me from doing that, but at least I can say that the short reservation list has all unique IP addresses.

I do have two different entries for the hub, one for the Wired MAC address and one for the WiFi MAC address. They are reserved for xx.xx.xx.150 and xx.xx.xx.151 respectively.

I can say that the C-8 is the only device on the network that disappears from the router's Connected Devices list, and has been very consistent. If things go as they have been for the last few weeks, the C-8 will stop being visible (though, still on the LAN at xx.xx.xx.150), and I will stop receiving push notifications on my cell phone again.

Are there any diagnostics / logs I can capture that can provide more info on what might be occurring?

Have you tried changing the ethernet speed setting? Whatever it is set to change it to the opposite. Some routers have issues with one setting or the other and some work fine with either so its worth trying to change it.

By these comments are you saying you are trying to use Wi-Fi while still having an ethernet cable plugged in?

@sburke781 - No, I don't have the WiFi enabled. I was originally using WiFi only for the C-8 until the "disappearing hub" issue cropped up.

When I moved the hub near my router to set up a wired connection, I left the WiFi configuration in my router for possible future use (changing the WiFi IP address to xx.151), and then set up the wired connection using the xx.150 IP address.

@jtp10181 - I am not sure if I can fully try your suggestion on the Ethernet speed setting. The C-8 is connected to a 100 Mbps/1 Gbps switch, I don't know what would happen to the switch devices if I tried to set the speed to the fixed 10 Mbps. For now, though, I set the Ethernet connection to "100 Mbps Fixed".

1 Like

Yes I forgot they added another option, just try the fixed 100 vs the auto negotiate.