How do I access my hub when internet is down?

We had the power go out and when it came back up, the internet was down for hours. One of my water sensors triggered the siren so Hubitat worked when internet was down.....but..
I could not do anything to access the dashboard locally (on ipad in same wifi network) and neither from phone app (which I think makes sense).

How am I supposed to turn off the alert /siren if I can't get to a dashboard?
Is this possible....I sure hope so.

Thanks for the assist ..
Tim

Is it possible your hub has changed IP address - can you get to your hub via http://hubitat.local/ ? then access devices to turn the siren off?

as @EVOLVING.HOME mentioned, you could have changed ip address'. Your best bet is to set up a DHCP reservation or set a static IP directly on the hub so you don't have this issue in the future. Also you can go to find.hubitat.com and if the hubitat has access to the internet and has a valid ip on your network it will be found.

Just to add to what previous posters mentioned, you can certainly use a mobile device connected to your local network while the internet is down. However, as you mentioned, your device(s) must be on the same network (subnet). The place to start is find.hubitat.com, then click on the link "Looking for a hub on your network that is already set up?". Alternatively, you can go to findmyhub.hubitat.com. If your device is not present, then it means that you are likely not on the same network. If the hub is present, validate that it's IP address didn't change.

Another possibility is that you were using the cloud link to the dashboard instead of the local LAN link ??? This was an error I did in the past.

3 Likes

If your hub isn’t on a UPS, it can boot up faster than your router after the power failure and not pick up the reserved IP address.

1 Like

:point_up_2:

This was my first guess... because?? yea, a learning opportunity in the past. :slight_smile:

3 Likes

If connected to wifi my phone will use mobile data if it cant reach the Internet through wifi.
Have to foce it to use the wifi

Thanks to all for the comments....I will investigate further....I do have the IP reserved on my router but I never thought to use findmyhub (great idea).
I think I will unplug my modem to kill internet and try these things out.
I'm glad that it should work: )
Tim

3 Likes

This is a bit riskier if you’re not network savvy. One could make the hub inaccessible. I believe it’s supposed to be a network address on the same subnet, but one that’s outside of the range of addresses assigned by the router to avoid having two devices with the same IP address.

4 Likes

I’m wondering if you are using an all in one gateway modem that was included with your internet package. I have always put them in bypass and used my own routers, but maybe they don’t function until they have an internet connection? My AT&T gateway doesn’t seem to complete its startup until an internet connection is available, but I’ve never tried to connect to it and test this theory.

2 Likes

I use a netgear modem and a Watchguard T35 firewall myself. Easier to control things than the allinone stuff the cable companies give out

2 Likes

Also my first thought.

And it’s easy to confirm. Does the link for the dashboard start worh the hub’s local IP address? Or cloud.hubitat.com?

@tim.ocallag This is usually the issue with no internet on mobile/tablet devices. They switch over to 4G/5G when the wifi has no net. Easiest way i've found is to disable the mobile data temporarily so that it connects back to the wifi and that should allow you to access the IP of the hub to control it.

will definitely try the suggestions tonight....got sidetracked putting in garden last nigth

Not foregoing any of the above recommendations, the issue can also be the router you are using. I have a mesh router that will not assign DHCP addresses when power is restored, but there is no internet.

The router is on my UPS with the other devices, but since there is so much load, I only get 1.5 hours of backup. In an extended power outage the HE hubs and my Home Assistant RPi should be shut down safely. But if they weren’t and then power is restored without internet, I wasn’t able to access them. To resolve this situation, I have set a Static IP address for the devices that I need to access in order to do a safe shutdown.

Here is the results of my study....net result, the IP or hubitat.local should work
image

That makes sense. When you are making calls to hubitat.com that is outside your local DNS so it's making a call to external DNS servers that it can't reach. Now you should make a DHCP reservation for anything IoT related if you haven't.

Yes, I've done that for all that I can.
The weird thing is my TpLink Deco router will not show my Hubduino devices

This topic has been marked solved by the community and subsequently closed.

Download the Hubitat app