How can I override a Motion Zone Controller?

I have a motion zone controller set up of two motion sensors in my upstairs hallway. During the night this turns the lights on when we go upstairs.

Last night for some reason the zone controller stayed on because one of the motion sensors never reset. It is z-wave and presumably the signal to indicate motion had stopped didn't get through.

So the lights stayed on all night.

So I thought to add something to my sleep rules to reset this (and other) motion controllers. But I can't seem to find a way to do this in rules? I could of course make sure the lights are off but this doesn't fix the underlying problem as the zone controller would still be showing motion and wouldn't trigger the lights if someone gets up in the night.

Is there any way to do this? Thanks.

If that really happens, the lights will already be on, and will go off x minutes after the new motion stops.

I find that sometimes my lights stay on, rarely, but it's likely because I restrict the times of operation (Simple Automation). I've taken to turning off the light, with a rule, a little while after the restricted time begins. Say, at 9:06PM when the restriction begins at 9.

I have a rule that turns all lights off (that I don't want on) at 3:00 AM, just for good measure.

Plus, I have a wireless switch, a ZEN34, on the nightstand that turns on and off all lights. One, day, hopefully not, it might also be useful to turn on all the lights on in the house from bed.

I'm not sure what a Motion Zone Controller is. Is that part of the Motion app? I've never used it.

There isn’t a way to reset the zone motion and the solution is to fix the device causing the zone motion to report active. Does your Zwave motion driver have a refresh command? Maybe in your night routine you invoke Refresh on it? This should then report inactive and the zone motion will ultimately report inactive based on your time limit.


I have found that motion sensors sometime lock on in the active state as their batteries expire. Just something to check.


Now that you mention it, one of the two motion detectors controlling that light I was talking about is down to 33%. I'll keep an eye on it. Thanks.

Most of mine are dead when they read 33%.


It is an Ecolink PIR. Battery is set at 80%. The generic z-wave driver does not have a refresh.

I will watch it closely as this may have been an anomaly. But back to my original question there is no way to manually override the motion zone controller.

My Ecolink reports crazy battery levels.

|battery|99|%|Carport Motion battery is 99%||||10/08/2023 06:26:00.633 pm|
|battery|61|%|Carport Motion battery is 61%||||10/08/2023 06:10:21.580 am|

and I didn't touch it.

Here's a Room Lighting instance that gets turned off after no motion or a timer:

You'd have to make some adjustments including remove 'don't turn off if stays pending'

Also note that most uses of motion zones are not needed:

1 Like