How can I fix a corrupted database following an update?

I was running 2.3.0.124 and trying to update to the latest 2.3.3.125. After the update, I see the message indicating the database is corrupted and I will need a soft reset + restore. That doesn't seem to work and I get a database corrupt again after the restore.

I was able to use the diagnostic tool on port 8081 to roll back to the previous version and that seems to work. What is the best way for me to update to the latest version without triggering a database corruption notice? Thanks.

@jlam Now go to settings, then backup and restore. Click download and download a current backup. This will clean the database. Goto port 8081 and do a soft reset and when prompted use the backup you made on your pc. After restoration shut down from the settings menu. Unplug power to the hub (at the wall not the hub) for 5 mins and power back up. Try update again. (when prompted during the update download another backup)

5 Likes

That worked for me. Thanks.

3 Likes

Likely you had some corruption in your original database. There was a major database change in 2.3.3 so likely the conversion process had a problem. Downloading the databsase to your pc cleans the database.

This topic has been marked solved by the community and subsequently closed. For further discussion on this topic, feel free to create a new thread under a different category to continue the conversation.

If you are logged in, click [HERE] to get started.

Download the Hubitat app