HousePanel Dashboard App for Hubitat


#484

silly question, just updated to the latest version, my housepanel is installed at 192.168.1.222:8445/housepanel/housepanel.php, when specifying the host ip and port in hubitat should the host ip just be 192.168.1.222 and the port 8445, I dont have to specify that its in the housepanel folder??


#485

The IP is correct. This is actually the IP of the he Node.js app on the same rPI. The port should be different. Use a unique port for the Node.js app. There are two ports - one between Hubitat and the Node app 19234, and the webSocket port between the Node app and HousePanel. The latter defaults to 1337. In your case the only time you need to use port 8445 is when you launch the HP dashboard I. The browser. By default I use the standard port 80 but your custom port will work too. I’m still fussing with the Node.js app to get it to work reliably. I’m close but it still might be flaky.


#486

Version 1.990 posted that fixes the hubpush feature. I just had a file in the wrong folder.


#487

Sorry for the delay. I think the install script had issues. Try the new version that I just posted.


#488

Still not looking good

pi@PiHoleO:~ $ sudo systemctl restart housepanel-push
Failed to restart housepanel-push.service: Unit housepanel-push.service not found.
pi@PiHoleO:~ $

Also is not asking what branch to install, which it was before.
I will try some more tomorrow when i have more time to play with it. The issue may well be something at my end.

Thanks!


#489

I took out the branch because hubpush is integrated now into the master.

Not sure what is happening here.

Will look further and get back to you.


#490

Looks like your systemctl calls are not working. Also the install script should be creating the housepanel-push.service file. Please check if it is there.

A workaround is to just manually make a .sevice file. It should follow usual Node protocols.
Turns out a sample is in the repo. Here it is:

[Unit]
Description=housepanel-push NodeJS Application
After=network-online.target

[Service]
Restart=on-failure
WorkingDirectory=/var/www/html/smartthings/housepanel-push/
ExecStart=node /var/www/html/smartthings/housepanel-push/housepanel-push.js

[Install]
WantedBy=multi-user.target

Just change the folder from smartthings to the actual folder name.

It also looks like your Apache didn’t restart for similar reasons. I don’t remember how to set up the auto start framework — maybe other can help you.


#491

Doc file updated on http://www.housepanel.net


#492

Thanks for the reply,
I checked and housepanel-push.service is present in /var/www/html/housepanel/housepanel-push
( if i remember correctly it was previously showing up in /var/www/html/housepanel before your changes)
Capture

Its content is:
[Unit]
Description=housepanel-push NodeJS Application


After=network-online.target \n\n

[Service] \n
Restart=on-failure\n
WorkingDirectory=/var/www/html/housepanel/
ExecStart=node /var/www/html/housepanel/housepanel-push/housepanel-push.js

[Install]
WantedBy=multi-user.target

I deleted the housepanel directory before my last install, after the install and moving over hmoptions etc it looks like this:

I will try with a spare PI over the weekend with a fresh install of stretch.
It is still working fine other than not having the new feature so at least i haven't broken it (yet) :slight_smile:

Thanks


#493

Sorry about all this. I’m still learning about Node and how it gets installed. Still must be missing something that is ore setup on my pi.


#494

I tried it on a fresh install of Stretch.

Apache issue looks fixed, but some different node errors.
How do you recommend installing npm (node)? i fear what i did last time is not correct. Or is the npm install supposed to be part of the install script

Capture


#495

Yea - I didn’t include a Node.js and a npm install in the script. Will add that. In the mean time do this first and the. Re run the script.

sudo apt-get install nodejs npm node-semver


#496

Still no luck

Capture

But the file is there:
Capture2

Not sure is this is of any help:

Thanks


#497

Really weird. I’m still remote this weekend and have limited debugging capability. Will look at it when I get home. Try getting any sample Node and npm setup working in the meantime.


#498

I'm a newbie to housepanel, I'm running housepanel on my unraid server in an Apache docker, I have been unable to get the new push feature working..

Just an idea, can someone just make an image of an SD card with a completely working version of housepanel that can be placed into a raspberry pi and then it just works??

I don't have a raspberry pi, but if a working image of an SD card was made available, it would certainly open housepanel up to less knowledgeable people..I would even be willing t pay for that SD card image..and a simple GUI with the ability to just click to get updates would be great..

Just tell me which raspberry pi to purchase, download the SD card image, pop the card in and that's it.. that would make things so much easier..


#499

What a great idea. Let me consider it.


#500

Quick question, I'm a little impatient and want to get housepanel with all it's new features running asap, I'm going to order a raspberry pi and Try and set it up myself, will the command https://raw.githubusercontent.com/kewashi/HousePanel/master/install.sh
bash ./install.sh

Also setup the push service automatically?

Or do additional steps need to be taken? Thank you so much for all your help.., I looked at housepanel.net install instructions and there was no mention of the push service..


#501

I just updated to the latest. As usual took me a little poking doing it manually but seems to be working well. Updates are lightning quick. Thanks as always @kewashi


#502

Can you post what you did to get it working manually? I can't get the automated install to work.


#503

[RELEASE]HousePanel V1.991 with Modern skin

By popular demand I have finally implemented a skin that gives the typical modern look of some of the other common dashboards out there. This skin is called "skin-modern" and is this release. A screen shot of what it looks like is here.

image https://discourse-cdn-sjc1.com/smartthings/uploads/default/optimized/3X/7/0/706146a2b700766d4004fba875d36d3ce694af12_2_690x269.png