Honeywell T6 Zwave Thermostat

Besides those few strange items with the Generic Z-Wave Thermostat dealing with half degrees C, and an occasional set-point miss/delay, is there any capability that is missing that you think (or know) it should have that is available on ST with the ST driver vs what the Generic Z-Wave Thermostat offers on Hubitat?

Nope. There is not much to a device driver, either you can communicate with the device or your can't (I have around 100 devices on my HE, and this is the only one that has some issues, not even sure it has anything to do with HE, although I believe another user confirmed the Celsius problem).

I have never used ST so I have no idea about that platform. But the difference between ST and HE is not found in the device drivers. I am no coder, but many ST device drivers are virtually identical to HE device drivers with some very simple changes.

The real difference is in the apps that control all the devices. HE has a built in app called Thermostat Scheduler and all of the Thermostat's settings along with the Thermostat scheduler are available in Rule Machine. I feel that HE allows me to do anything I want with my thermostat, but this is more through the HE app called "Thermostat Scheduler" and "Rule Machine", as opposed to through the device driver. So far my thermostat automations include:

  1. Changing the Heating and Cooling Set Points based on Mode. (My modes are: Morning, Day, Evening, Night, and Away)
  2. Immediately shut-off the furnace/air conditioner/furnace fan, as soon as a smoke/CO alarm goes off.
  3. Changing heating set-points based on outdoor temperature. ( I live in Canada, so when it hits -40, I want my heating set-points to be a little higher regardless of mode).
  4. Send an alert to my phone if the temperature in the house ever falls below a certain threshold (good when your away on winter vacation down south and the temperature back home is -30, if your furnace goes down, you come home to a house with a lot of broken water pipes).

Again, I have no idea what you can or can't do in ST, but I couldn't imagine that ST could do something with the Thermostat the HE can't. Everything I ever wanted to do with my thermostat was fairly straightforward on HE. I did have some difficulty with writing the logic in rule machine for adjusting Set-point based on outdoor temperature, but in the end it took a matter of a few hours for another member (thanks @napalmcsr) on this forum to walk me through it.

1 Like

Ok thanks for the info. Helpful.

I was also thinking of doing something like your number 3, as the temperature at the thermostat isn't always the best way to set the temperature in the house overall, and the amount of setpoint differential needed to get the house where I want it depends on the delta of the temperature outside compared to the desired temperature inside (the colder the temp is outside, the likely higher the setpoint needs to be and vice/versa). Was also planning to do some alerts like your number 4.

Honeywell send me one of these for functional verification.
Can someone clue me in on what isn't working or is missing with the generic driver?
This might save me a little time when I start working on this device.

Thanks for the confirmation the T6 Zwave integrates well with the HE device driver. I just ordered two from eBay, will be implementing similar rules.

With the Thermostat set to Celsius and HE set to Celsius, I cannot change the set-point to half degree (i.e. 20.5 degrees, 21.5 degrees, etc...). If you try to set this temperature from the device page the thermostat will quickly set itself to 4.5 degrees. On the following screen shot I have inputted "22.5" into the "Set Heating Setpoint" command box and about 1 second later the device page shows this:

Notice the heatingSetpoint is now 4.5 degrees (honeywell documentation states that 4.5 degrees is the lowest setpoint the thermostat can have).

This behavior does not happen if both the thermostat and HE are set to Fahrenheit. The other odd behavior, is that I am able to set the thermostat in half degree increments on the thermostat and it is then reported correctly in the device page. Here is a screen shot after I set the temperature to 22.5 degrees at the thermostat.


Since one degree Celsius is almost two degrees Fahrenheit, it would be nice to have half degree resolution to use in thermostat scheduler. This problem also makes the thermostat tile on dashboard simply a display device and not a place where you want to try to adjust, when you try to adjust on a dashboard tile, it increases/decreases the setpoint temp in half degree implements, if you stop on a half degree, the tstat will go to 4.5.

In the past, I did not realize it was the half degree setpoints that were causing the problem so at times I thought the Tstat was working fine in Celsius. Eventually I realized the problem was the half-degree setpoints that would set the tstat to 4.5 degrees. Here is a link to an older post where I wrongly believed it was working fine in Celsius and was pointing out some odd behavior in the Thermostat Scheduler app: Thermostat Scheduler won't operate properly in Celsius

Thank-you so much for looking at this problem, it is very much appreciated.

1 Like

Based on comments above about fractional degrees, maybe the thermostat’s “Advanced Z-Wave Temperature Reporting” could be the issue? Screenshot from page 10 of the Professional Install Guide:

I installed two of these about a week ago. Good quality hardware, easy to install and configure for my A/C-furnace and A/C-heat pump systems. I configured one of them (Downstairs) for "Advanced Z-Wave Temperature Reporting" - 0.5 deg F resolution reporting - and the other thermostat (Upstairs) I left configured in the default 1 deg F resolution reporting.

The Upstairs thermostat and Generic Z-Wave Thermostat device driver have been working fine; all events and commands with the Hubitat generic driver work perfectly. However, the Downstairs thermostat is occasionally sending a temperature that is bogus. Here's a screenshot depicting the erroneous reporting:

And here's the debug log around that same time (device 1880):

I have changed the Downstairs T6 Pro device configuration back to the "Standard" temperature reporting resolution - 1 deg F - and still I get these occasional bogus temperature values. Next I will try a zwave exclude, T6 factory reset, and zwave include to see if the thermostat/device driver then behaves correctly, as the Upstairs one does.

From the logs, the reported temperature of 720 deg preceded by a reported 72 deg would indicate some kind of scaling anomaly.

@mike.maxwell, hoping you can shed some light on this one.

From the manual: "The default temperature reporting resolution is 1 °F or 0.5 °C. When configured to ADVANCED, the temperature reporting resolution will be 0.5 °F or 0.25 °C. To change default temperature reporting to a higher resolution, go to thermostat MENU/Z-WAVE
SETUP/TEMP REPORT and set to ADVANCED."

Regardless of the above settings, the problem I described above still exists.

1 Like

@mike.maxwell, I've had two in place for several days now. Here are some log snippets from both. Some problems with zwave command parsing, and sometimes the same message logs many times in a short time interval.

Also still seeing the occasional bogus temperature (e.g., 720 deg F, ...) in the logs and in the device event history.

@mike.maxwell

The issues with erroneous temperature reporting with this thermostat (Honeywell t6 Pro z-wave) continue platform 2.1.7.127. I just paired one of these to Hubitat yesterday evening.

The erroneous temperature reported is corrected within milliseconds. Here's a snippet from the event log:

Do you need one of these thermostats to debug this? I can probably lay my hands on a second one and send it to you.

I have one, working on a dedicated driver for it right now, so far I've not received any bogus temp readings.
Can you enable debug logging and see if you can capture one of those bootleg temps?

Will do.

@mike.maxwell

Haven't been able to capture a errant temp yet. However, did find another bug. The thermostat (at least the unit I have) sometimes repeatedly sends the current temperature back to HE (example below).

While that is going on, if any commands are sent to the thermostat, the setting on the thermostat is changed; however, the thermostat doesn't report the changed setting back to HE, so the HE device page is no longer in sync with the thermostat (refreshing the device page makes no difference).

The only thing that puts them back in sync is to wait 5-10 minutes until the temperature reports stop and send a different setting change (different from the one tried above) to the thermostat.

In the example below, I tried setting the thermostat state to off. The physical thermostat reports as being off. HE reports it is still in heat mode.

42%20PM

don't know what to tell you about the excessive temp reporting, this has nothing to do with the driver...
The device is doing this on its own, the unit I have certainly isn't doing this.

It doesn't bother me much because it reports the correct temperature within milliseconds. I may try excluding and including the thermostat again.

Have you encountered the second issue? Thermostat not reporting successful setting changes back to HE? That one does bother me a lot more.

which settings specifically?, thermostats have lots of things to set...

The ones I tried were:

Set Heating Point
Set Cooling Point
Set Thermostat Mode

Note: This issue only happens when the thermostat is repeatedly sending the current temperature to HE (see below). While this is going on thermostat actually changes its setting, it only doesn't report the change to HE (so Hubitat and the thermostat become out of sync).

42%20PM

well sure, the device is too busy sending temperature events to respond to any commands...
I can't fix this, there's either something up with your mesh or the device itself...

1 Like

Going to try excluding and including.