Honeywell Pro built-in Driver skips refresh sometimes [SOLVED]

C7 [beta 2.3.4.117]
I have found over the last few months that my HW Pro thermostat does not reflect my Dashboard tile the odd time. If I do a manual Refresh of the thermostat driver the Dashboard corrects itself.
The theremostat always gets the correct heat setpoint data but the driver fields show the previous setpoint until a Refresh
I doubt it's a Beta thing as this has been going on for at least 10 beta release.
I will stick a Refresh in my WC polling pistons for now; not a huge bug :wink:


Thermo

EDIT:SOLVED - sort of :wink:
Sorry I thought I was still running the stock driver.
I am running @thebearmay version so not an HE issue.

What does the device page show in that instance - could just be a delay in the dashboard reading the data. There is also an option to require a minimum temperature delta from the last reading before reporting (defaults to 1°)

Device page is also incorrect. It only happens every so often so the Refresh fixs it.
As an IT guy/programmer we all hate intermittency. :wink:
Call me when it's a solid fault! :laughing:

1 Like

Download the Hubitat app