HomeKit Issues / No Response After Idle

Hi,
I recently purchased a C-7 when I saw that Habitat had HomeKit Integration now but I'm having a lot of trouble with it. I've searched the forums and tried a bunch of different things, but I just can't seem to get it to work consistently and getting close to just moving everything back to using the Ring as my Z-Wave hub, reaching out to the forums for help and hoping I can sort it out as it seems promising.

My problem(s):

  1. Alexa has a delay in which it is "Waiting for Hubitat" Once it initializes, it's blazing fast but it seems the Hubitat hub goes into a sleep mode of sorts after some time and causes the delay again if not used after a period of time.

  2. Siri/Homekit Integration works well...until again it goes into the sleep/idle mode. Upon initial pairing, everything works wonderfully. The voice commands, the touch screens, the rules, etc. However after some time everything stops responding and shows "No Response" in HomeKit.

Things I've tried:

  • Rebooted the Hubitat hub (ethernet connected)
  • Rebooted the AppleTV (ethernet connected)
  • Rebooted the Alexa/Echo Dots (5Ghz)
  • Relaxed home hub pairing security
  • Made sure everything was marked as a Switch
  • Restarted Integration
  • Reset QR and pairing code

They all get it to work in some form temporarily, but it seems if I leave my devices alone and it goes idle, it stops responding again.

Any ideas?

Hubitat actually doesn't go into any sort of low power or sleep mode. It's full blast all the time. That said we can try a few things.

First set dhcp reservations for all your iot devices. Alexa, homekit etc.

Make sure that all your apple devices are on 16.3

There was a recent hubitat platform update that fixed some alexa issues. Current is 2.3.4.134

See if any of that helps.

All the apple devices are on the current iOS, the Hubitat is on the latest update. The Z wave devices have all been updated to the latest firmware as well.

How do you do the dhcp reservations?

I did find the massive thread about this and I might be just having that same issue. I have to read through it but it all but it seems I’m not the only one.

You do that in your router's DHCP settings.

Hmm I think on that they were doing refreshes on the echos prior to use.

I definitely haven’t noticed any Alexa issues in quite some time (my wife would let me know because she is always ordering her around :joy:). Do you have this enabled?

I don’t have it enabled, I'll have to give that a try if it goes wonky again.

I ended up doing a couple more things this morning.

  • Software Update to .134 became available
  • Reset of Z-Wave, full device removal
  • Soft reset of Hubitat

I also switched up a couple of virtual switches that allowed Alexa/Homekit integration to contact sensors instead which created more devices but eliminated some potential looping of rules that I had with the switches.

After that, I decided to only pair a couple of Z-Wave devices, a couple of my virtual sensors, virtual switches, and rulesets to see how it was working first.

So far, it's been ok. But the real test seems to be overnight so we will have to see tomorrow. If it holds, I'll move the switches back over one by one to see if maybe one of the physical or virtual sets is the issue, same with the rulesets.

1 Like

Beware of creating ghosts when redoing your z-wave devices.

What do you mean by ghosts?

When I paired again, I reset the devices themselves to factory as well. Not sure if that addresses the ghosts.

This AM everything was responding. Time to add the rest of the devices back in.

If you have a failed pairing it can create a device known as a ghost. these are defined as having nothing in the routing column on the z-wave details page. They can and will wreak havoc on your mesh. If you have a failed pairing STOP!! Check your z-wave details page for a ghost, remove it. Factory reset the device and try again. Rinse and repeat. A lot of gotchas can be avoided if you look at this thread.

Download the Hubitat app