HomeKit/Homebridge Aeotec Recessed Door Sensor 7 Integration

Hi Community,

I was successfully able to pair an Aeotec Recessed Door Sensor 7 to my Hubitat and expose it to Homebridge using the Maker API app. The accessory in Homebridge looks perfectly integrated and the Open/Closed state is reported accurately and swiftly.
Please note that I am also using the Hubitat Maker API app to expose my Schlage BE468/BE469 Lock.

I previously installed the Homebridge Hubitat Makerapi plugin on Homebridge to expose my Schlage BE468/BE469 Lock to HomeKit, and it works fineā€”there is a slight delay with double iOS notifications but works as expected.

I expected the Aeotec Recessed Door Sensor 7 to just show up in HomeKit due to the Habitat Hub -> Hubitat Maker API -> Homebridge -> Homebridge Hubitat Makerapi plugin integration. Unfortunately it is not showing up in HomeKit.

I am not sure how I can tackle this differently. Any pointers would be very helpful!

Technical Details:
Habitat

  • Hubitat ElevationĀ® Platform Version: 2.3.0.113
  • Hardware Version: Rev C-7

Homebridge

  • Running on a Raspberry Pi 4 Model B 8GB RAM
  • OS Raspbian GNU/Linux Buster (10)
  • homebridge v1.3.8
  • Homebridge Hubitat Makerapi homebridge-hubitat-makerapi v0.4.15
  • Homebridge Hubitat Makerapi Config
{
    "platform": "Hubitat-MakerAPI",
    "name": "Hubitat MakerAPI",
    "app_url": "http://192.168.*.*/apps/api/11",
    "access_token": "********-****-****-****-************",
    "local_ip": "192.168.*.*",
    "local_port": 20010,
    "mode_switches": false,
    "hsm": false,
    "debug": false,
    "logFile": {
        "enabled": true,
        "path": "",
        "file": "",
        "compress": true,
        "keep": 5,
        "size": "10m"
    }
}

Did you go into the Hubitat Maker API and add the Door Sensor in the select devices section?

Yes, I added Door Sensor in the select devices section.

I just figured it out. It was a configuration (shown above) issue in the Homebridge Hubitat Makerapi plugin

I changed

"hsm": false,

to

"hsm": true,

and restarted Homebridge and it worked out.

Thanks everyone who took a look at the issue!

Download the Hubitat app