Homekit Devices Not Responding

Hello All,

I hope this finds everyone well.

I have a question / issue regarding the HomeKit integration and devices not responding. I know there have been a few posts on this so bare with me if you will.

For the longest time, pretty much since the introduction of the feature, it's been flawless for me with no real issues whatsoever.

However, over the last couple of days, I now get an issue a few times a day where the connection breaks down, this being, Apple Home shows all devices as not responding. Nothing really happens to cause this, no power outage, no network changes, nothing really, it just seems to loose connection between Hubitat and Apple Home.

What's even more strange however is that restarting the integration doesn't resolve the issue, I actually have to physically restart (power off / on) the Hubitat hub to get the connection working again.

Everything else, devices, Google Integration etc - all work fine during this time.

I have C-8 hub, connected via Wifi.

Is there anything I can look at or even provide for someone to look at (logs etc)?

... or does anyone have any pointers.

Thanks in advance,

This has been common for me. I don't think it's a Hubitat HomeKit Integration problem, because it happens with Homebridge too.

I've used Homebridge for years, still am, and every year or so I'd get the dreaded Not Responding. Then it would happen for a couple days, then go away after I'd done one of the two cures:

  1. Close out of the Home App on your phone completely. Open the Home App and it would work.
  2. Delete the appliance in the Home App and rebuild, requiring a change to the pairing code.

Cure 2 is horrible. Not so much the rebuild but putting all the devices back in their rooms in the Home app. I hate that task. I've found a process that keeps me on a half boil while doing this... I add only ONE device during the initial Appliance add (re-add). The process the Home app uses during the appliance add puts me into a trance and I can't remember for even a second, what device I'm trying to answer questions about. I can do one easily enough. After that, then I select more devices and those all end up in Default Room, where it's more taps but less trance inducing to put each device into a room.

I had to do Cure 2 twice in one day as a result of upgrading HomeKit Architecture to v16 a few months back.

This is true for me and Homebridge as well, but like you wote, it was more of a once a year thing and not a regular occurance. I haven't experienced this in a long time, but it's likely due to the fact that I now restart my Homebridge integration more regularly because I have one particular Homebridge plugin that works amazingly well, but does stop responding every so often.

To fix any issue, I've not had to do anything more than restart Homebridge for years now. It's a lot more stable that what the OP is describing with his experience using the built-in integration.

1 Like

I just did an update on my iMac and after the Home app was "not responding". So I restarted the HE integration, Homebridge and Home app. Now is OK.

This happened to me right as iOS/TVOS/HomePodOS 17 was rolling out to my devices. I made sure they were all updated, rebooted them, rebooted the Hubitat, and all was well again.

Hmmmm this is frustrating for sure.

So this is happening multiple times per day now - again after being stable for months.

I have rebooted all of my Apple TVs and rebooted my Hubitat multiple times as I have to fully restart the Hubitat to get the Home connection working again.

Are there any logs I can provide to help a dev potentially see if there is a bug?

Thanks in advance,

So I have an update to this...

While looking into this problem (which only started the occur over the past few weeks), I went back and asked myself 'what changed'.

So a month back I started using an Apple HomePod Mini to see what it was like. Right now we're a mostly Google Home house (20+ devices) but have Apple phones, computers, and TVs hence the desire to have Apple Home.

Long story short, the HomePod did not live up to the expectations and is still substantially behind Google in terms of capabilities but this isn't the point of this post.

So I unplugged the HomePod device and stuck it in the corner of my office. I don't recall exactly but this could be the time I started experiencing issues. When I went into Apple Home, I could see my multiple TVs acting as hubs with the HomePod as 'not responding'.

So I plugged in the HomePod again a couple of days ago. Its still not the 'hub' so to speak in Apple Home but it is now 'responding' and since this I don't seem to have had this issue any more.

Would there be any form of connection breaking down between Hubitat and Home if the HomePod was not responding? Is there an election for example to find what to communicate with?

Curiouser and Curiouser...

Both Hubitat and Homebridge have failed for me in this regard. Normally when I debug software I look for common denominator first.. which would be Apple in this case. Perhaps they aren't robustly informing their appliances of a change in 'master.'

It's completely possible that both Hubitat's programmers and Homebridge programmers have made the same error but given the two independent languages (C,Java,Groovy vs Javascript) it again makes me start to look elsewhere first.

I agree with @csteele, sounds like an Apple bug to me. Something with their home hub mesh is acting up when a registered device is offline. If you want to stop using the HomePod, I guess you should remove it from your account. I have one in my office I bought JUST to be the home hub (no apple TV here), and it also works great for music as a bonus. My Homekit via Homebridge works great. Only issues I ever had was when my HB server was on Wifi, once I moved it to ethernet never had any issues since.