HomeKit - All Accessories Not Responding

I have 15 ZigBee accessories attached to Hubitat running 2.3.6.146 All accessories were exposed to HomeKit through the built-in app. All was working fine, until an accessory wouldn't respond to a voice command which prompted me to check the Home app where I found that all accessories were unresponsive.

I first tried powering off my HomeKit hub (Apple TV) and Hubitat for an hour or so (as I think I read somewhere here that this was a first step) but when they were turned on again there was no change. Next, I deleted Hubitat from the Home app and did a reset on the HomeKit integration and the QR and pairing code.

After restarting Hubitat again, I was able to pair the bridge with HomeKit and went through the accessories setup, but they all showed "No Response".

I then went through all the above steps again, but this time removing the HomeKit app between Hubitat restarts. This time I didn't go through Accessory Set Up after pairing Hubitat with HomeKit, but the result is that I now have my "No Response" accessories all in the Default Room.

Short of factory resetting Hubitat, I can't think of a way forward. Any ideas would be appreciated!

I’m seeing the same issue, I tried the factory reset in the Homkit Integration and I noticed that my QR code didn’t change and the pairing code didn’t update. Everything was working reasonably well on 143…

Have you run software update on Apple TV?

Do both your Hubitat and your HomeKit hub have a DHCP reservation on your network?

Yes. The Apple TV is up to date and both devices have fixed IP addresses.

A post was merged into an existing topic: Blank app page

Make sure your Hub name does not have any special chars in it, another user found this totally breaks the Homekit integration:

1 Like

My hub was called ‘hubitat-1’ (but it was called this when I first installed in HomeKit - when it worked). Anyway, to be certain, I changed the name to ‘hubitat’, rebooted, removed from HomeKit, deselected HomeKit integration in every accessory, removed built-in app, rebooted again, reinstalled HomeKit Integration, reset this to factory, set a single accessory to have HomeKit integration, repaired hub with HomeKit, set/up accessory, and … it’s still unresponsive.

Is that your Hub Name or the Lan name? I think the issue was with the actual Hub Name.

image

image

It’s just ‘hubitat’ in both places

FYI, I have noted that you need to reboot your hub after you reset the HomeKit integration. Even if you had just installed it. If you pay attention, you may notice that the QR code does NOT change when you “reset” until after a reboot. This may cause a failure as the background joining info does not match the displayed QR code you scan to add to HomeKit.

1 Like

I’ve been rebooting the hub after every change, so that’s not it. Thanks anyway.

So you are actually able to get HK to pair to the HE bridge from the sounds of it? But once paired you cannot get the device state to sync up it just says unresponsive?

Have you changed ANYTHING in your Lan setup? Even a simple setting changed on your router could be causing it. Anything with Bonjour, mDNS, or multicast especially.

Your understanding is correct. The router/LAN setup has been constant throughout - I have changed nothing.