Homebridge nest cam integration not showing thumbnails properly

I’m new to HomeKit but so far I love the Hubitat integration. I wanted my Nest cameras in HomeKit so I setup homebridge and used the Google nest plugin. It works… sort of. The only thing I don’t like about it is the fact that the thumbnails on the home screen don’t show the actual camera image. Has anyone else encountered this? I can’t help but think I’m doing something wrong but I followed the instructions exactly as written when setting up the Google cloud platform stuff. It’s all Greek to me but I can follow directions. I’m wondering if the home screen is supposed to look like this or if I did something wrong?

I have done the same for Ring for my doorbell cam and I get a snapshot in the Home app, can tap that for a live view. I did have to install and extra piece of software on the homebridge server, ffmpeg which it uses for video conversion I believe. Should be in the instructions if you need it.

Ok I’ll look into that. I can see the live videos. Recordings are acting up a bit.

Ok I took a look at the ffmpeg plug-in. I’m using the following plugin - Google Nest Sdm. I’m not sure I need the ffmpeg plugin since I’m already using the one for Google nest. A lot of this stuff is over my head unfortunately.

Are you sharing the devices from Hubitat to Homebridge or did you setup a Homebridge plugin to work directly with google? It will probably work best if you integrate them directly with Homebridge.

So possibly you are using this: homebridge-google-nest-sdm - npm

You're right, That's what I am using. I setup the homebridge plugin to work directly with google.

I may have found the answer... Maybe I didn't do anything wrong and this is just the way it is...

Based on that discussion in GitHub, looks like you’re right.

Try this plugin, I am not sure if it only works with the old nest accounts or not but it was recently updated. I am using a similar plugin for my thermostat that works on both old nest accounts and google accounts. I am not a huge fan of the SDM implementation, it works but not great.

Also found this in the FAQ of the SDM plugin you are using now

I tried the plugin you suggested and had some difficulty. I tried several different methods to get the access token and used the manual authentication method… modifying config.json… and it still didn’t work quite right.

Thanks for doing some of your own digging. Much appreciated.

Perhaps I should just get the Starling hub?

Download the Hubitat app