Help with Rule Machine

Please help me write a simple rule that will take the temperature from a qubino Flush Thermostat device every X minutes and sent it to a virtual Thermometer.

I’ve attached a photo of what I have and obviously it doesn’t work.

What you'll need to do is create a local variable (or hub variable--and maybe you could use that directly instead of the virtual sensor? depends on the app, and that's another story...), then use the appropriate RM actions to set the value of the variable to a device attribute, then use a custom command to set the temperature on the virtual sensor to the value of this variable. Basically, you need an intermediate step because there is no way to directly access the value of a device attribute in an action without doing this first.

Alternatively: do you have a specific need to do this every two minutes? Because another approach would be to trigger on the value of the real sensor changing, then update the value of the virtual sensor then (rather than every 2 minutes). It's also possible you'd be able to directly use the built-in %value% variable then, though I'm not sure if numeric inputs would take this as a parameter or not, so you may still need the intermediary "real" variable workaround above...

Those are the general ideas. :smiley: Feel free to ask for more if you need help finding the specific actions.

I need to do this because the device is on a remote hub and it’s causing excessive events, it checks Temperature every couple seconds. So the idea is to create a virtual device on the remote hub that would only report back to the main hub through hubmesh only every 5 minutes.

How do create a local variable?

Is the temperature changing every two seconds? Can you post a screenshot of the device page? I’m not familiar with this device.




Could you post a snippet of the event log showing temperature reporting every 2 or few seconds?

You’ve configured to report only on a change of 0.5 degrees F, so it should not be reporting that frequently.

Got it!

Can you change the report to be >0.5F? Like 5F? And post logs from when you do this change. So we can see if the qubino responds?

1 Like

Under Commands, have you selected Configure?

1 Like

That maybe the answer. I changed it and it hasn’t reported anything yet. Thank you, I’ll keep an eye on it.

2 Likes

That wasn’t it

As @pseudonym suggested, click on the Configure button. That device is misbehaving.

Can you confirm using logs that the device accepted the configuration change you did?

See those pending changes - you need to wake the device for them to be applied.

Dumb question, how do I wake it?

It should be in the manual for the device.

And let's hope "remote" isn't too remote and it doesn't require a button hold :smiley:

Download the Hubitat app