Help with devices not responding to commands

I keep running into this. And its driving me crazy.

It can happen overtime. It often happens after an upgrade.

Basically after Hub reboots zigbee mesh comes online and I can see my devices.

If I look at the map its building

Take the 'Office Dimmer' for example.

I can operate this fine from the physical push switch and I see the data in the logs

You will also notice the logs reporting me using the device page (digital) on off button

However when issuing such commands from the WebUI, device page (or mobile app) the devices don't respond.
Yet the hub is seeing any changes (like if motion is detected)

This is a C8 (UK) Hub with Platform Version

It was all working fine on and I decided to upgrade to latest patch on 2.3.6. This resulted in again all my devices not really responding to Hub Commands.. (I did get some bad signature errors also in the logs). So I rolled back to and restored backups.

Now my hub its totally useless again. No Commands from hub seem to do anything.

This does keep happening and I don't really see anything in the logs that points to an issue..
All I can say is it seems very unstable

I use the Google Home and Chromecast App with this hub.

It feels like something is corrupt, best I can explain.. because looks like the mesh is doing what is should. Yet I don't have any visibility into whether a DB is corrupt or not..

Any help would be appreciated, and I need to understand the cause before taking action, because this keeps happening.. and wondering if the hub is somehow damaged?

I solved my own problem.

Was hyper focused on looking at logs and the issue was more foundational.

Interference and hub location

My Hub was on the wall about a meter away from a small MiniPC I had setup for my home media stuff.. Anyhow this is running on Ethernet, but did have a wifi/bluetooth board on it that I totally forgot about. it didn't even have the antenna setup..

It appears that there was enough interference to break it -> sometimes but not all the time.. very hard to see why.

Now with Wifi I have many mobile app tools to troubleshoot wifi channels/ network interference from other wifi channels.. etc.

But it seems this is a little different with ZigBee. (even though shares the same 2.4G frequency. (BTW my Wifi is both 2.4G and 5G, as some 'devices' only use 2.4g still)

Even after reading about channel overlays.. which i had configured my hub to use channel 20 power level 4, this at the time solved it.

It seems location and interference is the root.

However I still feel a little in the dark.

I still have the old Hubitat USB ZigBee Dongle from my C4 hub.

Was wondering would it be possible to use a tool like this with the Dongle on a Raspi to do some network scanning ?

Ideally would be great if this tool could just run on the Hubitat so you can survey your area for other problems.

BTW have just tried plugging the dongle into my Debian device and its picked up the 'CP2105 Dual USB to UART Bridge Controller' no problem.

I guess now it would be a matter of using the device with a tool to scan nearby Zigbee Networks? (Maybe)


While it isn't quite as full-featured as your example, there is a new Zigbee scanner tool in 2.3.6.

Oh yeah.. I looked at that on < 2.3.6 platform and it wasn't returning anything.

But now:


(Deliberately obscuring PAN Id)

SO assuming LQI and RSSI still mean the same network is ok now.

Interesting the other ZigBee Networks which have stronger signals in my house
(I know one is the Hive Heating Hub - which i plan to kill off once I am happy my lights work :slight_smile: )
(Another is my electric meter which has its own Zigbee network)

The others I have no clue what they are.. maybe will run one of the network scanners from my linux machine.

This combined with the Toplogoy diagram are useful tools, I do hope they keep coming because its often the crux of a lot of issues.. is things which we struggle to see what is actually going on.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.