Help: Sneaky hallway lights

Thanks so much @BorrisTheCat - that works perfectly and has such a nice transition over RM.
The last thing was that when my garage door opens in night mode (after 745pm) I have the hallway lights to turn on for 15mins. Now Since the new ML setup will fire in night, I setup the following, seems it would work ?
garage door ML

Mirror me (if the hallway lights are on turn the hallway VS on)

Then I added the VS into the ML app as a restriction

so that will stop the ML app turning the garage door rule off after 5 mins, give us more time to get the kids sorted etc. Seem legit ?

don't think so no, because when the light gets turned on via the motion it will disable itself. 1st you need to move the disable switch to the disable OFF as i'm assuming you want that rather than disabling the ON? 2nd dont use the mirror app, instead add the Virtual switch to the simple lighting rule along with the hallway light. Then when the simple lighting rule fires the light will turn on and so will the V switch, this will stop the motion lighting app turning off the light for 15 mins (Not that it would because it has to activate before it can send a off and surly your already in by that point?)

1 Like

I cant add a VS to SL - there is no option or restriction for it. Thats why I went for mirror.

• when garage contact triggers at night, turn on hallway lights to 10% for 15 mins
• mirror, if hallway lights turn on, turn VS on
• IF VS is on, disable on for motion lighting

Thats what I thought i'd done in the screenshots.

Not as a restriction as a switch to turn on and off your using that switch as a restriction in ML, not other way round.

Yes that's what you did but think about it run it through using a diagram if you can. Think the mirror app as pointless because the light it's self is also a switch (it has switch capabilities) so you saying when this switch turns on turn on this switch so it's doing nothing. So now you know that the light turning on is disabling it's self so now forget the SL rule and think about the motion. When that triggers and turns on the light boom that's it no more nothing you have disabled it.

yeah - cause I dont want ML to fire and cut the garage/hallway light rule down from 15mins to 5min.
lol, so what I have above is wrong ?
sorry again, not the sharpest tool in the shed.

I thought that's what you wanted and that's why you need to do what I said. 1st move disable to the off not the ON putting it in the ON is not disabling the OFF like you want. Then do the rest of what I told you trust me it will work.

1 Like

roger that cat!

I think I get confused with disable on and disable off. Im my mind i think - disable off - stop it turning off, disable on - stop it turning on. Maybe thats backwards.
Here was the revised - thank you again for persisting with me, im sure its painful to watch lol



*just tested this, lights turned off after 5.
I assume in ML I need to change the switch to disable on - VS off, I need to change that to on?

No that's correct but that isnt what you have. You have disabled the ON message rather than the off.

Now I see where your getting confused. It's not ON or OFF for the switch! That's just if you want the disable to activate if the switch is ON OR OFF state.

What I have been telling you to do is move the disable from the ON options (of the motion app) you need to put it in the OFF options because you want to disable the OFF (from the motion app) from running. That's why it's not working.


1 Like

thank you for the screenshot - I get it now.

1 Like

worked a charm, thanks again @BorrisTheCat!

1 Like

Hey @BorrisTheCat - really weird. But i'd say 15 mins into when the rule is meant to fire it doesn't but once it does it fires all night no issue. Very happy with it thanks.

Could i ask your help on another one.

I am after a single kitchen light to fire when lux is <35. Now i've got it almost there - but I find it firing and staying on when lux goes >36. My thought is that "motion" is still active and so it hasn't turned off because the motion is still active.
Basically in all modes except "in bed" I want the light to be on, if motion, if lux <35.
This is what I have so far..

I think there is a lux setting in the ON bits that you can give it a range to not turn on to. I'm sure I have it and it's in there but not at home to check.

Are your sensors battery powered? I have aeon multi 6s too and all but one is powered. The one that is battery doesn't report a small difference in lux or reports too often so that will be you issue here. I have the same issue in that one room, without adjusting the settings to report more (which will drain the battery) your kind of stuffed. Unless you plug them in like me. I have a 12v to micro usb converter and the recessing kit.

all 3 of mine are usb power.

1 Like

Did you join them when usb powered? I read somewhere that they may not set them self's up correctly for instant reports if not powered at join. I would turn on logging for the device and change the settings to report more and test them 1st.

You need a bigger "dead band" than that. What I would do is work out how much lux the lamp kicks out. So in dark with light on what is the reading let's say "34" that means you need a off of maybe 68 because when it turns off it will drop 34ish so you don't want it to turn straight back on. Then a ON off 15-30 maybe.

yeah they were all joined on USB power - never had a battery in them

its really not that much as the kitchen light doesnt hit the sensor. So on or off I still get the same lux readings really.

Lux ON and lux OFF is a hard thing to crack because it's not dim down then off it's ON 100 and OFF so you dead band needs to be more than the output of the lamp.

Ok so if the light isn't affecting the sensor "at all" you can have a smaller band, but still needs to be more than 0.

1 Like

<35 and >45 ?