Help: Sneaky hallway lights


#1

I am trying to get this motion lighting rule right, but I must be missing something.
I have a bunch of other ML rules and there is no issue there but this one has me stumped.

Basically,
At night > if multi zone setup turns to active > turn hallway lights on (to 10% dimmer).
My issue is its firing during "evening" mode.

The Rule

Current Mode is Evening (is evening mode from sunset 415pm and turns to night at 745pm)
2019-09-07%20(2)

ML was set per mode (night) if mzone fires turn on hallway lights to 10 percent, wait 5 minutes then power off. It fired during evening and just turned the lights off.

when I pause this rule, I have no issue with the lights turning off except when they are meant to. So i've isolated it down to this rule.


#2

This is correct you need to set the off settings and not set a off for evening. Alternatively you can also select disable off in evening mode and any others you don't want a off in.

Not on network at moment so can screen shot the exact settings.


#3

this is a "mode" motion light which i've set to night.
so technically it shouldnt fire in evening. Will make more sense when you see the screenshots


#4

Ok so you have to think of it like this. motion lighting is linking the motion sensor to the devices you tell it to. That doesn't change if you select per mode settings it just allows you more options depending on the mode.
So with this setup you can have lights set to "absence" manual ON auto OFF or "presence" auto ON auto OFF and you could do this per mode! Also another possible option is auto ON manual OFF in a mode.

ON settings
I want light 1 to turn on in mode A,B and C i want light 2 to turn ON in mode B and C. I then don't want light 3 to turn ON in any mode so i don't select it in the ON setting.

OFF settings

In mode A i don't want any lights to turn off so i tell it disable lights off in this mode. Light 3 isn't currently linked as i don't want it to turn ON but i do want it to turn OFF so i would add it to the OFF only in additional switches to turn off.
I also want the delays to be different per mode so i would fill this in.


in mine there is a light that is linked in most modes but i don't want it to turn ON in night sleep, but if i fall asleep i want it to turn off.


#5

Yep, I kinda get that.
I just really only want the mzone hallway motion sensor to turn on the hallway lights to 10 percent in the night mode. But they seem to be overriding and working in any mode if the lights are already on - which I dont want.


#6

Just select disable off in all the other modes simple :slight_smile: in the OFF settings.


#7

Ok @BorrisTheCat - so I went to RM and got it to work ( i didnt really understand what you said with ML ). But blow me down I dont like how RM turns the lights on, then tries to dim them down to 10% (and when they are already 10% they have this weird stutter) where ML feels a lot smoother to me.
Can you help me get it to work with ML please.

RM rule I made

now this one, when it saw motion in "evening" would after 5 minutes turn the lights off. But I restricted it to night. But no matter what would always fire in evening and my mrs would have to go to the remotec and turn them back on.


#8

Correct, although because you have the AND night I'm not sure why it was doing anything for evening as there is nothing in your false. But as it's a RM 3.0 no point digging to much into it.

Not sure what your after on your motion lighting one so tell me exactly what your after and when then I'll point you in correct direction. If you can let me know I'll do a screen shot walk through and a test set up to show you how it should look


#9

That ML screenshot above - still activated in evening mode (because in evening mode the hallway lights are turned on in that scene).
I basically am after a ML rule that mirrors the RM that I made at the top, that current ML rule still fires when I only want it to work in night mode.
Thanks for the help.


#10

Ok perfect. Too late for me to do some shots so will start here then do some shots tomorrow if needed. 1st in options for activate you can remove everything you have selected apart from the fade and the disable on during bits you have used (start with just that we can add the overrides back IF there required for your setup but there not required for what you currently want).
Then in the options for off also select all the modes you don't want the lights to automatically turn off in. That should be it.

You will probably want them to auto turn off in away mode so I would leave that un ticked.


#11

like this ?


#12

Yes apart from you have don't turn off if already on? Do you want that? You also have disable off in night mode I thought you wanted it to turn on and off in night mode?

You have disable on and off in away tick although I would remove the disable off in that mode personally.
Then you have disable on but not off during day? Do you want it to auto off just not on?
Evening is disable on and off tick
You have disable on in bed mode (makes sense) but left auto off (again make sense, if you fall asleep with light on it will turn off)


#13

basically if the dual zone fires in night mode, turn the lights on to 10%, for 5 minutes, then fade in 5 like this rule. I guess the away part doesnt really matter cause after 5 minutes the lights would turn off anyway and no ones here to trigger them.

the RM rule I want, but for ML

so this is right ?

thanks again for your help.


#14

no you have gone backwards. see below exsample

So what this is asking the app to do is link my hallway lights to my motion sensor.

when motion is activated (Options for activate) In all modes apart from night disable the turning On (because i have not disabled night mode)
when you do turn on take 5 seconds to get to 10 %

when motion inactive (off options) wait for 5 mins (the delay) and turn the light off. But I don't want you to do this in Evening and home mode (disabled). But i do want the off to be sent in all other modes (its up to you what modes you decide this) but in this set up i want the off to be sent in Night, away and night sleep because i havent disabled them. My reason is i'm turning the light ON in night so i also want a OFF, if the mode changes to night sleep i also want the lights to turn off as i'm asleep and if the lights were on when i left the house i also want the lights to turn off so the away is enabled. But I don't want the lights to auto turn off in home or evening mode so i have disabled the OFF in these modes.


#15

this is the equivalent RM rule for this set up, it looks rather easy. But the next stage is the addition options in the motion lighting and that would not be easy in RM it will make it much more complex where as the motion lighting does it with ease.


#16

I will have another go tonight, my brain must be mush.


#17

sorry so this was the same as yours, this will do the job ?


#18

it will, you just missed the disable off during the Day, unless you want that?


#19

evening is the only mode where the lights are on in a scene, which I dont want them to turn off. Thats what was happening.
if thats the case I can leave it as is ?
thanks so much for your help.


#20

Yes that correct if that's a mode that your turning the light on elsewhere and you don't want it to send a OFF then you disable the off so what you have will do that.