Help on Community Apps for newbies and Package Manger

I've gotten a few basic things set up on my new hub (motion, lights, etc) and I wanted to try a few community packages. I successfully loaded a Kasa driver and app, which worked perfect. This was a big win, because I've never used GitHub before. I downloaded the desktop software, but that was really confusing.

Eventually, I figured out that I only needed the .groovy file from the top level folder and that I could open this, select "Raw" from the Github browser interface and just copy / paste into Hubitat. This isn't covered in the Hubitat documentation on installing Community Apps and I think it would be the difference between success and failure for newbies like me. I put an image of this workflow below if it's helpful to anyone. Please let me know if there's a better way, but this worked for me.

After getting the Kasa app / driver to work, I wanted to try one or two more, but they all required a few different apps to be installed, so I thought I should try Package Manager. I installed the app in the same way and it seemed to load and authorize fine, but when I went to discover existing Packages, it got stuck on the hub security.

I don't have hub security enabled. I removed the app, re-installed and tried entering my credentials (even though security still was disabled). Still no luck. Could this have anything to do with the way that I installed the Community code, described above? Does Package Manager require Security enabled in some cases, even though I seem to have the settings correct?

I was going to try enabling security and then re-trying, but I still haven't tested reloading my hub with a backup config from my harddrive and I want to test that before enabling security and potentially losing access to all of my data if I goof something. Lol.

Any thoughts on what I might be doing wrong? Should I just ignore Package Manager and just go back to installing apps the standard way?

It could probably be a bit more detailed, but the relevant documentation page does suggest that the user paste the URL of the raw code page from GitHub into the box that pops up when one clicks on “import code.”

That’s actually a bit easier than the method you’ve outlined (although the end result is the same, the raw code appears in the code editor box and can then be saved as a new app).

I dont belive so. Make sure you have the Hub Security setting off in the Package Manager settings (not just blank user and pass), and maybe also turn on the debug logging. If you keep having issues I would post a screenshot of the debug logging on the thread for HPM (or here) and someone should be able to help out.


1 Like

It did say Raw code and that's the documentation I followed. Maybe you're a programmer and this is just obvious for you. I'm tech savvy but had no previous experience with GitHub. When I was confronted with all the different files, in the image below, I had ZERO idea what I was looking for.

I first grabbed the json from the root folder, pasted that and got an error! Lol. It would have helped to know I was looking for a .groovy extension inside the apps folder. I didn't even know what file type I was looking for! Now it will be easy the next ten times. But I was scratching my head at first!

Thanks. I'll give it another shot an enable logging.

Forgot to mention, yes you definitely want HPM (package manager). I like to keep my stuff updated so without it I would be lost! The installation is handy as well, makes it quick and painless. To me the best part is the ability for devs to push out updates easily (and users to easily update).


Still doesn't seem to be working properly. Here is a screenshot of the logs filtered for only Package Manager. I'm still not sure how to enable debug logging within package manager. It seems like this may not be available until after I do the discovery.
Here's a short video:

Once you install the code, and install the app, that is it. You shouldn't have any additional steps to make it work. There isn't any hidden security settings or anything.

So did you ever have hub security turned on? Did you try to turn it on, then deactivate security to see if something was "stuck" in memory someplace?

What do logs show if you open them in a new window, and try to go to HPM app like you did in your video?

But really, this is probably a question that should have been posted in the HPM thread [BETA] Hubitat Package Manager where the developer could see this. By the title of this particular thread, I doubt he would know to look here. I was expecting something totally different when I read the title, and not HPM erroring out.

I will tag @dman2306 for you though, and see if he sees this.