Help me work around Sharptools getting stuck and causing ongoing rule execution

Anyone have a recommendation how to work around this issue?

I have a sharptools dashboard with a HE virtual switch that triggers my goodnight scene (all lights off, doors lock, alarm arm., etc.).

Triggering the switch runs the rule, and then I have the switch set to auto-off after 500ms. This allows the state of the switch to be off in Sharptools and then I can execute it again when I want the rule to run.

Was working great, but ran into a scenerio a few times now where the virtual switch would get executed from Sharptools but seem to get stuck on. I.e. Sharptools didn't get the message that it should turn auto-off. I noticed Sharptools connection errors on the dashboard. As such, Sharptools appears to keep sending the switch on state to HE and causes my goodnight rule to run over and over.

Let's just say my wife is not impressed. Wondering if there is a solution I can program that works around (a button press instead of switch) or other.

500ms might be too fast. I have a momentary switch that turns off after 3 seconds and I don’t have any issues with my SharpTools dashboard.

@darron, sorry to hear that you are having issue with the virtual switch status not updated as expected in the dashboard. I am wondering if there's something else caused the goodnight rule to run over and over because the the connection error in the dashboard shouldn't keep sending the command. You may have to look into the log to see what has happened.

Here are few ideas that you may be interested:

  1. Increase the auto-off from 500ms to 1sec as @augoisms suggested.

  2. Create a "Good night" mode. Have your goodnight rule to be triggered by mode changed to this "Good night" mode, and add this specific mode or the mode picker in the dashboard. So you can tap the tile to change mode and trigger the good night rule.

  3. Create your good night rule in SharpTools Rule Engine, and add this rule to the dashboard, so you can tap it to execute the rule directly.

1 Like

Thanks for the suggestions. Is there anything more robust than just watching a virtual switch go to on to cover scenarios where it doesn't go auto off?

For example, watch the changed state only for the virtual switch and then execute the rule 'if' state is 'on',

I thought it was caused by sharptools losing connection or not seeing the virtual switch go off. The Shartools dashboard was showing the 'Goodnight' virtual switch as on and never responded to an off command. It could have been HE that didn't execute the auto off as well...not sure, but it reaked havoc as it kept triggering the goodnight command and turning a lot of stuff off in my home.

Any reason why the default scene switch won’t work?

I have my scene switches on a dashboard. I tap them and the scene activates/turns on. If you need to run a rule against your scene activation you can just watch for the switch’s state to be on.

I also have my scene ignore the off command, so if by chance things were out of sync and you needed to rerun the scene you would tap once to turn off (does nothing) and then tap again to turn on (activate scene and trigger rule).

Yeah...maybe that is better. I also want it to work via alexa...so might need the virtual switch still for that.

Download the Hubitat app