HELP! I tried VPN enabled on my AC3200 but I broke everything

OK, I openly admit to being a noobie at setting up a VPN and last night I proved it and had bad results. :open_mouth: :roll_eyes: I read through this thread to start

My current setup is a Motorola SBG6580 on Comcast (Xfinity) setup up in it's default setting as a modem, router, WiFi access, etc. About a year ago I upgraded the Wifi coverage in-house by purchasing an ASUS RT-AC3200 which works great. When I set up the AC3200 I disabled the DHCP and simply had it run as a wireless access point because I didn't want to deal with the change then.

But now that I have Hubitat Elevation and I want to access it off-site I see it's best done via VPN. So that is where I need some help. Last night I simply went into the configuration of the SBG and turned off the DHCP setting. I then went into my AC3200 and changed the mode from AccessPoint to Router which I thought would turn on its DHCP to kind of smoothly take over the responsibilities from the SBG6580.

Man of man did I break something good because right after both boxes rebooted to take on its new settings I lost all internet to my home. I lost all Wifi devices in the house including the HE so I can't even look at or control my devices/rules/etc. My devices are connected to the AC3200 but apparently, there is no "internet" at the new router location with DHCP and VPN. So all my wifi devices bulbs, Sonoff switches, konnected, Alexa, Google Home, etc are now dead...

Is there some kind of a website link or documentation that can hand hold me to what I am supposed to do to set up a cable modem only configuration to Comcast then a second box (like my RT-AC3200) that takes on the DHCP router and WiFi roles? I guess I am basically starting from scratch and redoing restrictions to hold static IP's for all my devices again on the new DHCP which is fine but is why I was waiting and then re-connecting all my devices again. @michaelahess I remember reading a long time ago of a network program you recommended to sniffing out IP's for helping setting up H801's and Sonoff's. I need to relocate all the new IP's being used by HE and the devices so I can at least access them once I get this up.

What did you break? Canโ€™t get into the router because DHCP is disabled?

I guess so. I ended up resetting the SBG so that it would turn it's DHCP back on and I turned DHCP back off on the ASUS and at least I have internet now but all my Wifi devices have new IP's so I can't access HE.

So the SBG was the host before or the Asus was? Who has the DHCP reservation table?

@dcoffing, this can be a tricky switch and it depends a lot on the settings on both the modem and the router. Make sure you gather the manuals for both devices before moving forward (they will have default passwords, ip subnets, etc that you may need). What I am posting below if very general and "how I would do it"...but may also take you to a point of no return. If you are not very comfortable with how to revert back to your previous config, feel free to ignore my steps.

Essentially there are 3 things you need to do but how to get there depends a lot on how those 2 devices operate.

If you have a laptop then that's the best device to use for the swap (it should have both Ethernet and wifi interfaces).

  1. You would need to set your modem to bridge mode. This would hand off your external IP to your router and let it "route" between your internal network and the Internet. This is probably the trickiest part because every modem allows this differently. While you at it, I would disable the wifi that is built in to this modem and disable any LAN DHCP service that it might also have. I would disconnect anything connected to the LAN ports of the modem except the pc/laptop you are using to configure it.

  2. Configure your Asus router as a router. It might be a good idea to set it to factory defaults (which should enable router mode) and also reset anything else you may have configured in the past but forgot about.

  3. Once both devices are configured as above. Shut down both, connect the router to the modem via the router WAN port and modem port 1 (again this may vary by device) .....connect your laptop/pc to a LAN port on the router.... boot up the modem, wait a couple of minutes, boot up the router.

Your documentation should tell you the default subnet of your router...eg 192.168.5.x.
Assuming the above is accurate your router should be on 192.168.5.1.
Configure your router as you normally would for Xfinity cable.
IMPORTANT: Configure your wifi SSID and password exactly the same and they should all reconnect once your wifi gets back online.

Once you are back online, the first thing I would do is start configuring your reservations, especially for your HA boxes. That way any configurations you have to redo, will only be needed once.

Just my suggestions but proceed with caution and prepare the family for some downtime. All your devices will have to get new ip addresses and may need some reconfiguration.

Good luck!!
Stephan

2 Likes

I was at church sorry for the delay and that my original post isn't clear enough but I tried. :slight_smile: Yes, The SBG was the original DHCP setup, I have since factory reset the SBG. The ASUS was originally only an access point with no router functions.
I just realized that I might have my cabling wrong at the ASUS? When it is setup as only an access point it doesn't matter how I connect to the SGB but since I changed the settings and function of both boxes I may have to change how the ethernet cable is connecting now into the ASUS which is now acting as the router? Ill check when I get back

Also take a look at this for switching to "Bridge mode" is you go that route.

https://arris.secure.force.com/consumers/articles/General_FAQs/SBG6580-Bridge-Mode-Setup

Got it all working again! Well at least as the internet and the ASUS being setup properly to be the DHCP anyway.

Thanks @stephack @SmartHomePrimer !

Now the issue is I went into the current connections of the DHCP table and I don't see the HE hub. I will have to reboot the HE hub but since I can't "see" it I am unable to do the preferred shutdown

Any ideas on how to get access to the HE hub or get it to regenerate an IP address with the new Router I just installed?

If the HE hub does not get a new IP on your router, I dont believe you have much of a choice but to pull the plug.
I'll have to keep that in mind if I ever need to make any subnet or dhcp changes....Shut down hub first.

Update :
I just found this in the forum. I wish I saw this earlier this morning :open_mouth:

Should not be a problem if your HE hub only had A DHCP reservation. Once it reboots, it should get a new ip and register on the habitat portal.....at least I hope it will :slight_smile:

2 Likes

Crossing the fingers and pulling the plug. . . . .

1 Like

:pray:

That did it. :grin: The HE hub got a new IP and it is showing up in the router logs and the http://portal.hubitat.com/

Now to get busy reserving the IP addresses for all my devices with the new router setup.

3 Likes

And save the router config when you're done if it allows it. I can't tell you how many times I've forgotten to do that myself :flushed:

1 Like

I am in the middle of troubleshooting after getting the new AC3200 setup. Having inconsistent behavior in HE and I thought did I name something (devices, RM, etc) poorly? I have used ( ) - . _ and didn't know if those are part of the taboo characters.

I also have two Lifx bulbs that won't work any longer in just the Lifx app and won't reset and reconnect to Lifx app, the same thing with a couple of my Sonoff switches, H801's just inconsistent behavior and operation.

I thought I read somewhere about best practices on the naming of devices or such about strange behavior could be due to strange device names? Anyway, I have searched in the documentation and the forums about naming practices and I can't find that post anywhere. I think it could have been @patrick posting it but I can't find a reference to it about NOT using special characters and he listed what those special characters are to avoid using. Anybody help me find where there that is?

I think there were a couple of posts by @patrick. Here is one...keep in mind the list of characters posted here may be incomplete.

Device Name vs Device Label in Drivers

1 Like

I remember having difficulty resetting these bulbs in the past as well. I can't remember the "trick" I used to force the reset. Are they the original A19's?
When I get my Wifi back up later today I'll try to reset one.

Yes they are. It is the the 1000 lumen output model. I am able to perform the 5 off-on reset and get the red,grn,blu,wht flashes. I go to Settings and connect to the A19 as an access point and it is says it is setting up this accessory to join "pPCp" which is y 2.4GHz WiFi but it then gets stuck and times out after several minutes with "An unexpected error occurred. Try again."

Yes that is what I thought... I used a bunch of these especially () .

:thinking: I think they changed the reset process since I last had to do it. I remember it being fairly simple and required me only to flip a tiny notch switch on the side of the bulb. I just looked up the procedure on the website and it list the above procedure instead.

Download the Hubitat app