Help! C-7 Error 500 After Update. Unable to Do Anything

Have used the C7 for years without issues, but can't seem to get this thing back up and running.

Had an update and then was presented with the dreaded "Corrupt Database" error. Did a soft reset, didn't work. Tried rolling back to the previous version. Didn't work.

Now I'm stuck with a 500 error and unable to do anything. Tried a power cycle, no luck.

Please help! I use this thing for an awful lot and the thought of setting everything up again is more than daunting.


Can you still access the diagnostic tool?
If yes, then first thing is download all of your backups from there for safe keeping.

When you say the soft reset "didn't work", why not? Did you get another error or is the hub getting stuck at boot?

If you did the soft reset and were able to restore from a backup but that caused an issue, then try going back further in your backups. Some people have had a backup or two be corrupted itself. Try all your backups newest to oldest to see if one will work.

1 Like

I did grab all the Backups prior. Thank God. No access to the Diag screen anymore. Beginning to think this update bricked something.

The hub would revert, but would then come back with the Corrupt Database error again.

I continued to revert to the next version and now stuck with 500 on every screen.

What color is the LED? Blue means the diag tool should be up, but platform is not.
Check your power supply or swap out for something else to verify.

The diag tool is also giving a 500 server error? I have never heard of that before.
Please try using an inCognito browser tab to rule out a browser cache problem.

Have you tried doing a network reset using the hidden button on the bottom? Hold for 7 seconds then let go, LED will blink then hub reboots. If you had a static IP set on the hub it might come back up with a different IP.

If you get back into the diag tool make note of the version of the hub platform and the diag tool (two separate version numbers).

It is pretty rare that hub will power up but the diag tool does not work, it is very hard to break the diag tool itself. But if the LED is off or you cannot get to the diag tool then there is no other path to recovery :frowning:

Also, I am logging off for the night soon, but I will check back in the AM.

1 Like

Let me take a pass at it in the AM. I've been on this thing for hours.

I'll keep you posted, but had no idea about the lights or the button on the bottom.

But how do you get to the Diag tool if there's 500 errors?

There a direct link I can try?

Port 8081


Replace with your hubs IP

The Diagnostic Tool is independent of the platform itself, so an update isn't going to affect the Diagnostic Tool, even if the platform isn't running. I would first check the network if you are unable to reach the Diagnostic Tool. There could be something as simple as your router changing the ip address of your hub, or you are trying to connect to the hub from a different network (segment) that can make the Diagnostic Tool seem unreachable.


Alright, got into the Diagnostic portion.

I'm still unable to revert back to any previous versions though. Keep getting a Corrupt Database error everytime.

Is there a way to see what about a Database is corrupted?

Do you mean all of your backups are saying it is corrupted?
You are doing a soft reset + logs purge from Diag Tool then loading a downloaded backup after it reboots?


Yes, all backups are saying corrupted. I have 2 recent and then one from July. No way they're all corrupted.

Here's the details from the Diag Tool versions

Hubitat Diagnostic Tool
Platform version:
Hardware version:
Diagnostics tool version:

Try these steps below. To revert to 2.3.7 it is in the "Advanced" menu.
For the debug disable endpoint, the main platform needs to be booted.
You can also try booting up fully without restoring from a backup, just to see if that works without issue. Then you can try to load a backup using the UI at Settings > Backup .

If you can get it working on 2.3.7 then you could try updating back to current

Might not be a bad idea to get the latest diag tool also:

Navigate to http:// [Your Hub IP] /hub/cloud/updateDiagnosticTool , wait a few minutes (you will not see a progress report), and the latest Diagnostic Tool version will be downloaded if needed.

If you see the Corrupted Database message, it means that you can access the hub's interface. If that's the case, you don't need to try to reverse to 2.3.7. Just navigate to this end point in a browser:


Then reboot the hub from Settings.

Then update to the latest platform version and let us know if that fixes the problem.

1 Like

Probably could also try updating to .140 from the diag tool using the Download Latest button (then Restore Previous) as well, not sure if that will help anything or not.

1 Like

Reverted back to 2.3.7 via Advanced.

Now I'm stuck on the Initializing Hub: 15% - updating database.

Going to give it another few minutes then am going to go back into Diag and revert back to the version before.

Followed all the above and still f***ing Corrupt Database.

I haven't updated to the new Diag Tool yet, so I'll try that, but I'm running out of options.

There's no way 3 previous backups can all be corrupted. Whatever this update is most recently has basically made my device unusable without completely starting from scratch.

So you were able to turn off the logging and rebooted the hub and have the same issue?

Correct. Followed everything above.

It's really strange. No matter what I do, every backup is corrupted.

And sorry, to be clear, things function correctly when I revert. It's up and running.

The issue comes with trying to load any one of my 3 Backups. All show as Corrupted.

There goes the hope to recover. This sounds like the hub has a hardware issue.