Having trouble getting off the ground


#1

New to Hubitat, not a coder but decently tech savvy, so I hope Hubitat works for me.

I set up my Hub and can connect.
Purchased a Xiaomi "Body" motion sensor https://www.gearbest.com/smart-light-bulb/pp_257678.html?wid=1433363&currency=USD&vip=15022849&gclid=CjwKCAiAyfvhBRBsEiwAe2t_i0O1SWJJO9k3cMKlQcSv0QkqmpmjrrVMIdIVnZpOEq7hmMOVPoEYfBoCQdoQAvD_BwE

and a leak sensor, and two button switch.

After a few tries, I successfully added the body sensor using the original xiaomi motion sensor drivers available in the forums. It stays connected and is reporting battery.
However, it does not log motion. I set up a rule machine rule to text me when it sees motion, haven't gotten a text, and the activity log shows nothing but checkins and battery status.
The leak sensor initially showed up when I tried to pair the body sensor, but I wanted to focus on one at a time and didn't pair it. Now it doesn't show up, even when rebooting the hub. I can't get the switch to show either, though I am not entirely clear on how to put it in pairing mode (tried holding 10 seconds to reset, and 5 clicks to "test range") No help.

It wasn't initially clear that I had to find the custom drivers and couldn't rely on Zigbee Generic Motion sensor, but I got that cleared up and it started showing more detail, but no motion.

What are my next moves?


#2

Have you tried the drivers here?

Need help loading custom drivers?


#3

That is where I got them


#4

Is there a senstivity setting?
I know my Aotech model does.
Maybe it's set too low?

I saw there where two motion sensors.
Have you tried both?


#5

You started on Hubitat with what is probably the most difficult device to pair. Xiaomi devices are non-standard and we're just lucky they happen to be close enough that Hubitat works with them (and you need a custom driver besides, as you discovered). It should only get easier from here for you. :slight_smile:

Normally, when people have problems with these, it's becsuse they entirely fall off the network. However, I see you say yours are still reporting battery status and check-ins, so that's probably not the case. But they should check in approximately once an hour. If that's not happening, likely did fall off the network (and if they miss one of those, they likely will fall off). Problems with these are documented in another thread, but it usually boils down to being either outside the range of the hub or routing through an incompatible repeater (only a few have been tested and known to work well with Xiaomi devices; many have been tested and shown to cause problems with them).

If everything besides motion is working, try clicking "Configure" on the device page if you haven't already. That tends to be a good idea after you change ZigBee drivers. Also make sure you're using the correct driver for your device (actually doesn't matter anymore if the "original" and "Aqara" drivers were merged into one-- I can't remember for these--but if not, check that).

If it isn't checking in hourly, try pairing directly to the hub or through a "compatible" repeater. You can't force this but can pretty much make it happen by disconnecting "bad" ones during pairing of the device.