Having trouble Find Hub

I am trying to setup a new C7 hub and having a lot of trouble.
Mysetup is modem is connected or Orbi mesh and I plug in Hubitat into a switch. (A)
I also tried putting my old router into the Orbi router and plug into Hubitat into that. (B)

It seems that (A) never works because Orbi broadcasts 2.4Ghz and 5Ghz network on the same SSID and my laptop/hubitat is on different frequencies.

I got (B) to work once, Find Hub on find.hubitat.com can't find it so I had to manually enter the mac address of the hub for which the hub immediately pops up. But most of times I can't connect to it. I did get to the Welcome page however after a few minutes when I try to connect to it again I get a timeout when connecting to it. It's being two weeks and I feel Hubitat is completely unusable.

Welcome to the community and sorry for your troubles.

I'm not an orbi guy so bear with me a bit. The Orbi has a small Ethernet switch built into it. is the HE connected directly to that switch? If you go to the UI of the orbi do you see the HE in the list of devices? If so make sure you have a DHCP reservation configured for it. That will ensure it gets the same IP address every time. It is possible that's your issue, thought it could be a few other things as well.


I use Orbi here and have zero issues with it. Can you find the hub IP and attempt to connect to it via that?

1 Like

Is your HE plugged into the primary unit or one of the satellites?

1 Like

Second this. Same goes for all of your smart devices like Echo, Google, or even your phones.


I connected the HE to the Orbi router and its no use.

I even disconnected the device from LAN, but somehow it still shows up when I enter the mac address on find hubitat page..

Did you contact support? support@hubitat.com

Edit in 2023: this no longer is the correct contact. That email is not monitored.

did not know this support existed.
When I tested it I am 100% sure putting it in the Orbi router does not work (because of same SSID different bands issue?). Is no one else running into this? I need to do a search.

The SSID issue would apply, if it were to apply at all, only to wireless devices connecting to the network, not to something plugged into one of the switch ports. If all of your other devices are working OK using duplicate SSIDs it shound't make any difference connecting to HE.

1 Like

They no longer respond to this email. :frowning:

Welcome to the Hubitat community. :smiley:

Correct. That was written 2 years ago when procedures were different.

Did you need help with something, or is this just an observation? I am not sure if that was a question?

Sorry, I am new to Hubitat and was hoping this would be a smooth transition, so when I was having issues finding my new Hub, I found this thread. I posted about my issues just now on here, so I hope I can solve it with some help!


I’ve just got my new Hubitat C7 and I’m having issues finding the hub as per the instructions. Here’s my setup:

  • Eero router in the home
  • Connecting Hub to switch
  • Eero detects Hub, assigned IP and MAC address(which I have reserved for Hub)
  • Hub has blue light
  • Using Chrome browser on same network as Hub
  • Tried finding using MAC address
  • Stuck on “looking for hub”

Any help appreciated

I see you just posted in a separate new thread. I think you should just handle everything on that other new one instead of in multiple places where it gets confusing for everyone. The information in this thread is many years old, and a lot has changed since then.

1 Like

Gotcha..ok, I'll monitor that. Thanks!