Having issues with Hubitat showing correct device status

The bulbs outlined in red are current On, full brightness. However the Dashboard (and status in hubitat>devices) shows that they are On w/ a Brightness set to 0. Additionally the switch above and to the left of the 4 bulbs shows in the dashboard as "off" when the bulb group is On.

The bulbs outlined in orange are all Off currently, however the Dashboard shows them as being On as well as the Bulb Group "Livingroom Light"

The bulbs outlined in yellow, are currently on, but shown as off in the Dashboard.

I'm not certain what the issue is here. The status of these bulbs was never an issue when running Hass.io on a Pi w/ Zigbee Adapter.

The status in Hubitat is never accurate, and changes randomly. I can toggle the light off, the switch will update correct to show off, but then if I open the Dashboard hours later the switch on the Dashboard indicates its on when the bulbs are not.

I had given up on Hubitat some time ago, but annoyed with the thought of wasting $150 on a paper weight, so Im trying to give it a fair shot but its turning out to annoy me more than it being a overpriced paper weight.

Skip the dashboard until you get the status of the devices working correctly in the driver page.
There are two main reasons for the issues you are having

  1. incompatible device and or driver match
  2. weak and or bad mesh.

Some details regarding the deployed zigbee infrastructure would be helpfull...

1 Like

The "driver" is built into Hubitat, using the "Sengled Element Classic" type.

The Hubitat device is less than 5 feet from the Master Bedroom Bulbs.

"Hub Mesh" is not enabled on any device.

All bulbs in the house are Sengled E11-G13 which appears on the Hubitat Supported device list, which is why I spent a lot replacing all bulbs with them.

so all you have is bulbs?, no repeaters?

1 Like

There are a few SONOFF S31 Zigbee Smart Plugs throughout the home.
These are supposedly repeaters, according to their online documentation.

Yes, they do act as repeaters.

I have one in my Hubitat mesh and one in my Home Assistant/zigbee2mqtt mesh.

When I switched from SmartThings to Hubitat, I had some communication issues between some devices and my hub.

I was advised to add a repeater in the same room as my Hubitat. I added a repeater about 8 to 10 feet away from my hub and in the same room, and it worked.

I think maybe the Hubitat radio/antenna is just a little weaker than SmartThings, but adding a repeater fixed everything and now I’m very happy with Hubitat. Please don’t give up on Hubitat, it’s a great system.

There is one of the SONOFF S31 in the same room as the Hubitat.

There is at least one in just about everyone room almost; accept the bathrooms.

MAybe zero help - but as a thought on the bulbs that are on but not on - 3 things actually.

There was a problem I had exactly like this before and it was frustrating - turns out the driver I was using didn't work well if you set a bulb to 100. try 99. to be perfectly honest I think it was sylvania or ledvance or osram... older bulbs. I don't recall.
Are the bulbs in a group? turn off the optimization and group messaging, then enable metering at some small value like 50.
My gf reported bulbs not turning on this AM getting ready for work - the bulb showed on at HE but there wasn't light. The bulbs turn out to not like being set to dim value less than 15. she had set them the night before from 100 to 15, then turned them off. Morning Rule was supposed to start them back at 100. Logs said it fired but the bulbs were all 'stuck'. I flipped the switch on the wall off then on, and they returned to normal.

Download the Hubitat app