Harmony Hub Mute/Volume doesn't work

Greetings. I'm fairly new to Habitat, I'm trying to use the Harmony Hub Driver to mute the TV in an adjacent room from my office (I often keep the news on in the other room while I'm working, and I want to be able to mute everything I may be listening to if I get a call). I set up a rule to turn off my office radio as well as mute my TV, but I can't get the mute to work in the Harmony driver. It worked once while I was setting it up, but I haven't gotten it to work since. I tried removing and reloading the drivers, and that doesn't seem to have done anything.

I can turn on the TV and cable box, and change the channel from Habitat, but the mute (or setting the volume) doesn't seem to work at all. Does anyone know what I may be missing?

Just to be clear...one can not “set the volume”, as the Harmony Hub can only adjust the volume either up or down. This is exactly the same way the physical Harmony remote control can only adjust the volume up and down relative to the current volume level.

Using my Harmony hub driver, you can “setVolume” to a value above or below 50%. Setting it above 50%, will cause the driver to issue a volumeUp command. Setting a value below 50% will result in a volumeDown command being issued. After each, the volume level in the device will snap back to 50%. This feature was added to allow a dashboard tile to adjust the volume of the current activity either up or down. Personally, I just use the physical remote control.

As for MUTE, that just toggles the Mute State of the current activity. Again, there is no way for the Harmony Hub to know what the current mute status is of the audio device. If the mute and volume buttons on your remote are not working, then chances are good that the Harmony Hub driver for Hubitat will not work either.

3 Likes

Thanks for your quick response.

I just tried it again, and now it’s working. I have changed nothing in the configuration since I had tried a couple nights ago. I had tried the mute button, as well as the Volume Up/Down buttons in the device, as well as in a rule, and none of them worked. Now the Buttons are working, haven’t tried it in a rule just yet, but I’m assuming they will work there.

I don’t know why it’s suddenly working, as I have not made any changes to it. Weird.

Thanks again.

Download the Hubitat app