Hanging on Update - Unable to update from to

Update from to on C7 was successful and event free.
However, update from to never completes. Package is downloaded and extracted fine. But applying the update never finishes. Hard reboot reverts the hub back to Hub remains accessible through out the process.
Tried, a clean reboot before upgrade - same behaviour
Tried a hard reboot and the hub reverts back to previous version
Tried hard reboots followed by update multiple times through out the day. Same issue. Hard reboot reverts back to
In the evening I have noticed that none of the motion lighting rules were working. Digitally switching lights on and off worked, but not the rules based lighting.
Ended up restoring a backup from the night before and now I am back to a restored version of System is behaving as expected. But can not upgrade to

Iā€™d want @gopher.ny to chime in first, but a possible sequence:

  • Download a good back up
  • Soft Reset
  • Upgrade
  • Restore backup

That's always a good idea!

Go to the diagnostics tool, click Restore previous version, and pick from the list there. 129 is on the hub already, you just need to switch to it. I'll check logs to see why it can't switch on its own.

1 Like

Thanks @thebearmay and @gopher.ny.
I opted to try the method suggested by @gopher.ny first and that did the trick.
In diagnostics tool - restore previous version I could see both versions and
The hub switched to the latest and all seems to be working as normal. I have tried both motion lighting and dashboards to switch lights on and off and all is good again.

Thanks heaps! I wish I had reached out earlier.


I too had no trouble updating to .128 yesterday, then this AM I'm stuck at Applying update to .129... have tried a reboot, then tried @gopher.ny 's suggestion to restore and select the .129 and it seems to be back up. Maybe support can find the problem's pattern by checking out my unit as well.... Just a thought. But thought I'd chime in to confirm that suggestion worked for me as well.

Edit: I'll add that I have two C-7's, one updated fine, the other nope.


Thanks for your feedback. We are investigating, but luckily the workaround posted in this thread has been 100% effective so far.

1 Like

Minor update 130-133. Same problem, same fix, same hub... hope that help.

1 Like

Same thing for me as well.

This time I rolled back to .128 and I'm leaving it there until which time it seems to be resolved.

@gopher.ny & @bobbyD - Minor Update from .133 to .134 same problem, same fix, same hub, ... my other hub still updates like a champ.

I'm doing these updates to try and be involved and help resolve the issue, but if it's not helping y'all I'd just assume not do'em. Seems like without willing users reporting back it's harder to figure out...

1 Like

What model hubs are yours?

I've also been having issues updating. Never had problems prior to 2.2.9.xxx.

Yesterday was with I had download failures while "verifying download". Tried a couple different times with the same result, "Download Failure". I then went into my browser and cleared the cache and retried the update- Success!!!

Then this morning, I seen another update was available (, I tried updating 2 different times and again had "Download Failure" while "verifying download". I decided to again go into my browser and clear the cache. Retried and Success again.

I'm not sure if there is a direct link to the issue/resolve but it worked twice for me without hesitation. ???? ...just saying

I have a C-5 that has been running great since installing a year or 2 ago. I use Google Chrome browser on a Windows 10 PC. I usually install updates a day or 2 after they're made available.

I bought a C-7 for my son a few months back and it seems he has a lot of issues with his hub. I think the C-5's rock and would like to get my hand on another and another....

I've identified the root cause, a long running app or device job that prevented shutdown in each examined case. There will be a fix (forced shutdown) in the next iteration ( It's not going to make update to work any better, but every version after that should be fine. Sorry about the delay.


Similar issues but i reboot then immediately apply the update. Seems to work for me.

@gopher.ny wouldn't it be good to identify the long running item... is there a way for us mere mortals to do so on our own? Seems like the more I know about what my unit is doing the more I can dial in good behavior and remove long running things I don't really understand are still going and maybe can do another way.... in my case i suspect its delayed actions in rules, which break anyway in a reboot. just a question. Thanks for finding a fix!


Yeah, that can become another tab on Logs page, and it will definitely help with troubleshooting. It's been there on the list, just a matter of priorities...


I live in a fantasy world I'm sure, but I always thought 'a list' of those delayed actions, was time stamped in a file, and that was worked on as the times came along, and then read after a reboot to keep things humming along. when a delayed action gets done, stripped from the list, etc. Oh, how naive!!:joy::rofl:

I guess I just need to be more thoughtful before rebooting the beast. Thanks for the info!

They are indeed stored in the database and fired at the time they were scheduled for. You're pretty close.

1 Like


I have 2 C-7s and 1 C-4. The C-7's have handled the updates perfectly. The C-4 however, with just about every update in the 2.2.9 family, downloads, extracts and applies, but never reboots. Just hangs there. Goes back to the main menu. If another update comes out, and you click on it, it goes back to the rebooting screen. If I pull the power and plug it back in, it comes back up and has the newly applied version running. Then when the next update comes out, same thing. So I apply the update, and then when it hangs on reboot, I pull the plug.

Rather than jumping to pulling the plug, you ought to first see if you can get to Diagnostic Tools at port 8081, and doing a reboot there. You are taking a chance (unless the hub light is red) of corrupting your database.