[Guide] Updating Firmware and ZWave Replace

So everything went mostly fine using this method to update my 4 Zen30s. I was able to add them back to the hub using the replace method. But, I did run into one hiccup.

For two of the four I had used your driver to delete the child device for the relay and then create a new child using your driver so that I could get it to show as a fan in Google Home and not as a light. Those 2 relay devices are not working through zwave commands anymore. I suspect there is nothing I can do other than creating a new child and reconfiguring everything to use that. Just thought I would mention it.

By any chance, do you know what was fixed in the Zen30 1.11 firmware (and where to download it)?


I was mostly interested in the addition of parameter 30. Toddlers are very good at accidentally reprogramming these switches.

I'm struggling with this. I've completed the firmware update across the board, i've swapped most devices and forceably removed most others. However, when i run a Z-wave repair, i have twice as many failed nodes as fine ones. How do i repair these? I've read something about "Ghost" nodes and i just dont know how to tell which is ghost vs. failed real node. I'm very new to Hubitat.

Can you post a copy of your z-wave details page?

1 Like

By firmware update - you mean the devices firmware? Did you also update the Hubs firmware? Look for the firmware update button on the Settings/Z-Wave details page. If it's there then run the update.

Some Z-Wave devices after updating their firmware might require you to exclude and re-include (or replace).

Generally speaking do not need to run a full repair, a targeted repair on individual devices is usually a better idea with Z-Wave+.

By forcibly removing devices you might have caused "ghosts" - devices that exist in the Z-Wave table but are basically non-functional. Here's what you can do:

also agree with @rlithgow1 - post your Z-Wave details page!

To further clarify, the Z-Wave Firmware update button is pointed out below...only appears if there is a Z-Wave FW update available.


Just tried and it says i can't upload media into a post... first time on the Forum. screenshots are PNG, also tried JPG.

Updated the hub and the Z wave firmware prior to any device updates.

It will take a few posts before you can do that unless we can get @bobbyD to change your new user status.

1 Like


Join the Owners group and you'll be enabled to post pics:



lets try this again!

Holy makeral is your mesh a mess... Every one of those with the discover button on them need to be removed.

Start by shutting down from the settings menu, unplugging your hub (at the wall not the hub) for 5 mins and power back up. Go to the settings page and hit refresh on every line that has the DISCOVER button and remove that ghost. If you can't you need to shut power off to the device that created it (likely the device below it) then try removing it again. You may have to get a z-wave stick with the silabs software to clean up that mess if you can't remove all the ghosts present. This is more of a mess than my divorce...

No Way Wow GIF


Oh boy, your Z-Wave Details are kinda a mess, unfortunately.

Before we go any further:

  1. Shut down hub from Settings menu
  2. Pull plug (from wall, hub connector can be fragile)
  3. Wait one minute
  4. Plug in hub and let it boot up
  5. Go to Z-Wave Details page and post again if it's different.

You do appear to have a lot of issues...majority of devices have no info in Route column, that's not good.


Well crap. Did not have this issue prior to updates. I did buy a Zooz USB Stick that will deliver today and downloaded the software already. I’ve never used it, so will have to mess with it and read that post someone linked to above.

@user1842 Yeah follow the directions in ghost removal directions with it. No wonder half your stuff isn't working or working poorly. I'd almost consider nukeing the radio and starting from scratch (not a full hub reset just the radio). It would likely save a lot of time. How does your table look after the power down and unplug?

1 Like

A radio reset with that many devices would almost make a full hub reset desirable, because it is going to leave a whole bunch of hub devices that aren't linked to any radio.


Working through this. Most are removing, one isn’t.

BUT, if I press refresh and they pop up with a route, does that mean they’re active and not “ghost”?

Both of these are doing that.

You need to finds the ones that created them and power them down (likely the device below them) The reason they may not remove is because the device that created them is still pingable. If you can't, you will need the z-wave stick and the silabs software. Go ahead and shutdown again, unplug for a couple of mins and power back up to see if they remove. If not the stick can do it.