Groups and Scenes

No. You would have to look at the states of the individual scene activation switches.

As stated above, there isn't a way to see "which scene" is currently on/set (multiple scenes can be active at the same time, right?), but you can cram a bunch of scene switch statues onto one tile if you want with something like: [Updated] Super Tile - Icons have arrived! :)

1 Like

I believe there is an issue with the scene status display on the "Apps" page. The status does not reflect any status changes even if the "Apps" page is refreshed. But this is only a display issue. Tagging @bravenel.

There are 2 ways to get it to display status correctly on the "Apps" page

  1. go into the specific scene app and press the "Done" button, or
  2. go into the app without pressing "Done", go back in your browser, and refresh the "Apps" page
1 Like

I get an error message in the logs when I have a Scene that has both dimmer settings and button pushes:

java.lang.NullPointerException: Cannot get property 'switch' on null object (checkScene)

There are no obvious performance issues. I don't get error messages in Scenes that are just button pushes (no dimmers).

I will investigate this issue.

Update: This bug has been fixed, will be in next release. Also, fixed the app label being updated correctly.

1 Like

The fix for this has been released: Hub Update 2.1.1

1 Like

Anything I have with a CT bulb in it never reports correctly in the apps screen. I can go in and recapture the scene and as soon as i re-activate it, it always shows as not-set. I've given up trying to figure that out.

Please show a scene that doesn't show the right thing.

OK, what am I missing? Isn't this what it's supposed to be? When you turn the scene off, it's not set. When you turn it on, it is. ??

Well, show me one that doesn't work correctly, not one that does work correctly.

Did you not see that a bug was fixed? The bug had to do with this issue.

This is the one that I have that doesn't work.

Reports as not set even though it is in fact, set.

It appears that the color temp settings are not being saved during a capture. i re-captured and it reports as 2703 but that is not saved in the scene.

Ok. If what I showed you works correctly, then all of my Scenes have been working incorrectly for a long time now :-).

Show the scene itself. I have to have something I can try to reproduce. But, don't expect another response from me tonight ----- done for now.


Whenever you get to it is fine. I've lived with it forever. Never thought it was a big deal but since someone brought it up, figured I'd throw mine out there too. Thanks for taking a look!!

In the original scene I set the lights to a CT of 2700. For some reason the device (hue RGBW bulb) doesn't like 2700 and goes to 2703. So, i recaptured figuring it would update the settings within the app and it didn't. So, i tried changing them to 2703 manually and that didn't work either.

1 Like

Hey @bravenel,
At 745pm I have the mode change to night (mode manager), I have simple lighting activate a scene "phase two" every night. Two things:
The scene is set to "not set" at the top (but I was sitting here at 745pm and it triggered the phase two scene.
Secondly the dashboard didn't update that "hallways lights" is now switched off. (phase two is to turn off the hallways lights, which is does perform but didn't update the switch)

-actually, with the dashboard, I probably need to use the group "hallway lights" VS the bulbs in that group, is that correct for it to show up correctly in the dashboard as off? (its just in the doc for scenes it showed picking individual bulbs)

This sounds like a device issue, not a Scene issue. What happens when you set the CT on the device page, to either 2700 or 2703? What does the state show after each such setting? What do the device events show?

This is not a dynamic page. So unless you refresh the page it won't be updated.

1 Like

But when I changed the setting in the scene to be 2703, the 2700 still shows up for some reason.

Is that just an artifact or is that a problem?

I tried to create a new scene not adjusting any of the settings, just using the capture and it still did not show the On setting correctly. And all of the Event Subscriptions showed as True within the app properties.

Like I said, investigate the device. Scene goes on what it gets back from the device.

Yes, the device reports the same as what is being seen in the Scene app.

I am seeing the same thing with scenes that just have regular dimmers in them. They never show the correct status on the apps page. I just figured that wasn't something that worked the way I thought it did.