Grouped RGB Bulbs error: Command 'setColor' is not supported

Hi there. I'm totally new to Hubitat. I just started setting up my hub two days ago. Yesterday I added some really cool Sengled Colored LED bulbs. They work great and are super responsive when changing color manually in the Remote dashboard. I grouped a few together, and when I open the group, I have the color pallet, but moving it changes nothing, and I get the following error:

java.lang.IllegalArgumentException: Command 'setColor' is not supported by device 7. on line 594 (method dashboardCmd)

I've tried toggling Zigbee Group Messaging, Use setLevel Command, optimization, and metering, but none of that changed anything.

Can anyone point out my mistake, or is it just not possible because there is no "colored bulb" in the group activation device type drop down? That would seem to be a blatant omission though...

Thanks for any assistance!

By what means?

I went to Apps, added Groups and Scenes, clicked on groups and scenes, created a new group, added my bulbs, selected bulb as the group device type, and clicked done.

What is device 7? You can open it by

your-hub-ip/device/edit/7

Show what driver is in use, under Type...

That's why I'm a novice. I confused two things. Device 7 is not the group. It's a Meross mss560x. So we can skip the error message, though I don't quite understand, why it's involved. It is however the dimmer switch that powers the group of Sengled bulbs. Despite my confusion, the individual bulbs change colors, but the group doesn't.

Here's a screenshot.

And should the question arise, where I got the driver from, it's the one from Daniel Tijerina and Todd Pike, which I modified slightly to fit the device better.

Next step to troubleshoot is to show us the logs from activating the group. Screenshots only please.

I tried a bunch of things, and deleted and re-created the group. It is now working, albeit fairly slow to react, and the colors seem off compared to the slider. Also Group Bulb Dimmer-2.1 is set as the default Type, but Group Bulb Dimmer seems to work a little better. So as far as it not working goes, solved, but I now wonder about the colors and speed.

You are off on your own swapping drivers like that. My recommendation is to import the group in Room Lighting, and use is as an instance of Room Lights. Same functionality, newer code base with more features.

2 Likes

Hi. Thanks for the assistance and input. The community drivers work fine for my Meross switches and dimmers. I mistook the java error for the group. The Sengled bulbs are using the built in HE drivers.

I don't know what I did wrong, but I've created a couple of groups in the meantime, and I can change them in unison. I think also that some UIs change colors, brightness, etc. with the sliders on the fly, and in others you need to hit the set button. So that was most likely my issue. Like I said, I'm brand new to HE.

I'll have a look at Room Lighting.