Group of 2 lights don't all turn on

I have a Group of 2 individual LIFX lights, but only one turns on with the first click of "On." I have to click "On" multiple times and in quick succession for the second one to turn on. If I wait just a few seconds between "On" clicks, it won't turn on at all, it's almost requiring a double-click.

I've tried uninstalling the LIFX Integration app. I've factory reset both LIFX bulbs. Everything is updated, the bulbs' firmware and Hubitat version. I'm lost on what else to do.

Disclaimer: I do not own any LIFX bulbs but here are some general things.

Can you turn each bulb on/off individually with no issues?

In the group:

  • Remove and recreate the group for giggles if you have not already done so.
  • Make sure on/off optimization is disabled
  • You can try setting metering and a delay.
  • enable logging and see if anything interesting pops up.
  • Group activation device is set to "bulb"
  • set "Use group device to indicate if any members are off?"
2 Likes

This is an issue with your WiFi network. I have multiple groups of LIFX bulbs, but a very robust WiFi mesh. And have never run into this issue.

1 Like

Does the LIFX driver report signal strength? Otherwise/also they might be able to use their cell phone and an app to monitor signal strength near the bulb(s) in question. The other possibilities could be LAN related of course (dns, gateway settings, etc)..

1 Like

Excellent point. It does.

@ungph00

What is the signal strength (rssi) for each of the bulbs in your group? It is shown on the device page.

By way of comparison, the RSSI values for my bulbs range from -30 to -53.

2 Likes

The ones giving me trouble are -38 and -47.

@erktrek, that's the thing, even when I go to the individual bulb's Devices page and turn it on and off, it doesn't work the first time. I have to click them pretty quickly about 2-4 times before anything happens.

Hm could be. It did start happening after I got a new router, but it's the TP-Link WiFi 6 AX3000, which I figured would have worked better than my super old Netgear. I've set each of my bulbs to a static IP address on the TP-Link.

Do you have the same behavior with the lifx native app?

You might check the wifi channels and placement of your router/antennas; the behavior you describe sounds like it could be interference/packet loss.

2 Likes

Nope, works perfectly fine in the native app.

What would I be checking for in the wifi channels?

Since it works fine with the native app then it would seem the issue is some sort of communication thing going on between the hub and your network. Maybe try some simple things like replacing your ethernet cable connecting the hub.. dunno. Do you have your hub set to a static IP address?

Can you turn on logging and post some logs of this happening when you do it from the device page? Also maybe review your logs in general to see if anything weird is happening.

:thinking:

1 Like

Download the Hubitat app