Groovy error using Alexa TTS from Rule machine

Hubitat Elevation® Platform Version: 2.3.0.124

Hardware Version: Rev C-7

Getting errors in log file for speak message actions in Rule machine.
Only happens in rule machine. Other apps like notification etc. are working as expected.
Have tried keeping volume field blank (only possible in rule machine v5.0 and v5.1 automatically defaults to volume of 50 that can be changed but not blanked). No luck.

Error:

groovy.lang.MissingMethodException: No signature of method: user_driver_ogiewon_Child_Alexa_TTS_386.speak() is applicable for argument types: (java.lang.String, java.lang.Long) values: [its a yellow bin today, 50]
Possible solutions: speak(java.lang.Object), sleep(long), every(), grep(), inspect(), split(groovy.lang.Closure) on line 5875 (method speak)

You need to update your Child Alexa TTS driver to a more recent version. This was fixed in an April 2021 revision. You will need to use either the "Import" button on the driver page (should pull it since he specified a URL in the driver code, assuming that was always there), or just copy/paste the code yourself: https://raw.githubusercontent.com/ogiewon/Hubitat/master/AlexaTTS/Drivers/child-alexa-tts.src/child-alexa-tts.groovy

3 Likes

Thanks heaps @bertabcd1234. That worked!
I manually updated the driver for Child Alexa TTS and it was picked straight up by my rules.
Didn't realise I was on an old driver and just assumed that HPM would have picked up the update.
Thanks again.

This driver isn't in HPM (many developers use it, but not all)--otherwise you're right that it would normally catch this. Glad it helped!

2 Likes

Download the Hubitat app