Govee Wifi Lights in a group

Hi Community,
I have 9 Govee can lights in my den that I just installed. Using the Govee App, I can individually address them, and they work fine. I've created a group so I can control them all at once. When I actuate this group, the lights go on/off one at a time, rather than as a group. They're not zigbee, but Wi-Fi, so the group messaging doesn't apply here. Any suggestions? :slight_smile: I also have them grouped in the govee app, but that group doesn't seem to be exposed to HE by the Govee Hubitat app I found in package manager. Any help is appreciated. :slight_smile:

First you are spot on in that none of the Govee API's exposes their groups. So there is nothing I can do to add the Govee Group to hubitat.

What integration are you using and what driver was loaded if it is mine :slight_smile:

When you grouped it in the Govee Home app how did you do it? Was it dene on the Home tab I the Govee Home App, or was there a way to group all the can lights together from the device page?

If they support LAN API that may help improve the responsiveness from commands so you can just turn them all on at the same time from the hub.

1 Like

I'm using your app code, @mavrrick58 - The driver is the "Govee v2 Color Lights Driver" - I do see there are a 2, 3, and 4 driver in there. I haven't explored which of those do what, though. Any advice is apprecaited. The model of light I'm using is the H601A

Grouping in the Govee app was done on the homepage, yes. I have a group called "Den Group". That works pretty well from the Govee app.

when you say using the LAN API, you're referring to toggling the "Enable Local LAN control" to On?

Yes do that and re add the devices by their ip.addresses

To enable LAN API perform thses steps.

  1. Ensure in the Govee Home App the device supports LAN API and it is turned on.
  2. Setup a DHCP reservation in your router for each light device.
  3. In the device driver in HE turn on the switch and click save
  4. A new option will appear in the Device preferences section to Input the IP for the device. Enter the IP and press Save again.

At thay point the driver is using LAN API to talk to the device.

Then whatever rule you are using should act on all of the devices at the same time. It may not be perfect but should be better.

That said i will post a request to Govee to support Group controls. You may also want to check the settings for the devices to see if they can be paired together. I dont have any of them though so can't test that myself.

The multiple "Govee v2 color Light Drivers" are because there is a fair variation between device features. The Govee Integration app looks at the device abilities and supported commands and selects the correct driver. So you really shouldn't ever change the driver. Occasionally if something new comes up or is added i may need to add a driver, at that point I will give advice if anyone needs to change there driver or redeploy devices to use the new features. .

I don't see the LAN API in the Govee Home app, under the device, so I'll assume it's not supported?

you need to turn off bluetooth and connect to the device via wifi for the toggle to appear

tried that. According to their list in the app, Wi-Fi API isn't supported on this model

Well it said my h7050 wasnt supported either and it is.

If your device is not in the supported devices list for the LAN API it is possible it will still work.

The best way to be 100% certain is to first make sure the device is connected to our wifi and then in the Govee home app open the device and click on the Gear icon. If jt supports LAN API with about 15 seconds you should get a toggle for it.

The toggle looks like this image.

It that toggle doesn't appear it is not supported for LAN API. It is a very good possibility it doesn't unfortunately as it is basically a light bulb device and none of the bulbs support it.

as i said though at least in latest app. the lan control does not come up for devices if you are connected to them via bluetooth.. at least it didnt for mine till i turn off bluetooth

That ia different from my experience. I have had devices take a long time for them list the Lan control option, but i never turned off bluetooth for it.

1 Like