Govee Integration V2

I did now and I'm still seeing the Null Pointer errors. I have never "migrated" these to be child devices. And I went back and read all that you wrote and I have to say it's pretty confusing. This is a "legacy" device I think you would call it. I'm ready to pull the bandaid off and redo everything if that's what must happen to be in a supported state. Is that what you'd suggest? Is there an obvious way to recreate all my Govee Devices to be child devices?

OKay. I followed the directions in post 123 and did the "#" thing and sure enough it recreated one device as a child. I'll do that to all five of these and re-do the rules. And then I'll find out if the setEffect works.

Reporting back that the child version of the device does do the setEffect w/o error. I have do work through all of these including the rules. Unfortunately these devices are on my AUX hub and are meshed to my MAIN hub so I have a number of steps to go through here. Thanks though. I think it's just grunt work at this point.

EDIT: All done. Rules updated. Mesh Updated. Etc. So far, so good and now all my Govee devices are under V2 and child devices of the Govee Device Manager. Thanks for the support!

In the last release i move the function to trigger the scene data load to its own routine. That is called by the new sceneLoad command on the device or by the Govee device manager driver. You could of triggered that command to get the scene data loaded, though not exactly the best solution. I will add in some logic to check for this condition and run the scene load process

I updated from HPM and after some initial panic with scenes and DIY I got it all working again. One minor issue is that there seems to be some new log traffic with the setEffect command. I don't see similar messages when using activateDIY.

Do you have debug logging turned on? That should go away if you turn that off.

I double-checked everything - I've got the level set to Warning in the app, and the Device Manager and the child device both have debug logging turned off.

I just bought the Outdoor Ground Lights (H7052). The integration didn't find them nor did Home Assistant Govee integration but both find my other 2 Govee devices. Does anyone have any suggestions? Settings in Govee app seen to be identical.

I got cocky. The app finds the two other devices and I hit Next but they didn't get added.

EDIT: is manual LAN setup better way to go?

Looking at the loggs, it looks like you are running the Govee Integration V1. Can you verify which one you are running for me.

Manual Lan API install is a way to go if the device isn't avaliable other ways.

I will check to see why it is generating logs.

Hi @mavrrick58,

I hope you're doing well. I wanted to take a moment to thank you again for all your assistance. Your support has truly encouraged me to move forward with this project, and I'm very glad I did.

I recently discovered that Govee in Canada had discount codes on Amazon, so I made my first two LED strip purchases. I got the H70A1, which I have wrapped around the skirt of my deck, and the H619A1D1-ca, which I have placed under my bed frame.

I have my API code and went to HPM to find the Govee Integration v2 drivers. However, as I am new to LED strips, I'm not sure which driver or drivers to select. The options available are:

  • Govee v2 Color Lights 2 Driver
  • Govee v2 Color Lights 3 Driver
  • Govee v2 Color Lights 4 Driver
  • Govee v2 Color Lights 4 Dreamview Sync
  • Govee v2 Color Lights Dreamview Sync
  • Govee v2 Color Lights Driver
  • Govee v2 White Light Driver

I believe I need the Govee Manual LAN API Device, but I am quite confused by all these driver choices. I've skimmed the forum, but I am experiencing information overload.

Could you please provide some guidance on which drivers I should be installing?

Thanks again for your help.

Best regards,


I think I am good now. I figured out how to add the API and manually set up the LAN-enabled device. It looks like I can turn it on and off successfully. However, I don't think I have set up scene management correctly. Since I am still learning about Govee, I hope this will come with time.

One thing I am stumped by is the "Set Effect" > Effect Number. How do I find that?

So first the Manual LAN API driver is a very limited driver intended for devices that dont work at all through the cloud but for some reason only LAN API. It is rare and should only be used as a last resort. Honestly so much has changed i am not even sure if effects will even work with it right now.

For the drivers question you really should probably install them all. The App looks at the device info provided by Govee and pics the driver based on your devices abilities. Then if you want Lan Control you can enable it.

Unfortunately there isn't a good way for me to say x device needs y driver.

If the device supports scenes they will be listed under the device state section of the device page.

One last thing about scenes when used with Lan Vs Cloud API's. The cloud API will list the scenes shown in your govee APP. The Lan API is curated and only shows scenes i have added. So if you get a new device with a new model number i may not have it added for Scenes yet. Many folks have helped by extracing scenes for new devices and sending them to me to be added.

Hi @mavrrick58,

Thanks for the follow-up.

I'm a bit confused because I thought I followed the steps in your first post, but it seems that may have been incorrect. I'm unsure how to proceed from here.

I tried running the install again from the HPM to add the drivers, but nothing happened. The process did not run, and it didn't show me the list of additional drivers available.

This is interesting because if you added new drivers, how would one install them?

So I could pick the missed drivers, I then attempted to uninstall the app via HPM but encountered an error:

"Error Occurred During Installation: An error occurred while installing the package: Failed to uninstall app, it may be in use. Please delete all instances of this app before uninstalling the package. Be sure the package is not in use with devices."

I tried deleting the LAN Device I created and the Govee v2 Device Manager device, but this did not resolve the issue. I received the same error again when trying to uninstall via HPM:

"Error Occurred During Installation: An error occurred while installing the package: Failed to uninstall app, it may be in use. Please delete all instances of this app before uninstalling the package. Be sure the package is not in use with devices."

I checked, and there are no more devices showing up, just the app in Hubitat.

Could you please advise me on how to uninstall the app so I can reinstall it, select the missing drivers, and then add the drivers? Or is there a way to just add the missing drivers to the app?

Also, after reinstalling and adding the API key to the app, will pressing 'done' in the app automatically create the device(s), or do I have to add the device(s) manually?

Thanks you for your help.

First , you shouldn't need to remove/uninstall anything.

in HPM you want to use the option to Modify the install package

Once you go to that menu. Select the Govee Integration V2 package and click next. It will give you a drop down to select items to be installed or uncheck items to be removed. Simply select the new drivers and then click on the next button. It will start the modify process to install new devices drivers.

Once that is done go ahead and setup the device using the device selection page to select your device. If the devices don't show up click on the option to refresh your device list.

HPM actually has code to trigger a update when this happens and will install them for you as missing items

The uninstall failure is because HPM's uninstall process simply remove the app from the hub. If you still have it listed on the Apps tab in Hubitat the app is still installed to be used by the user.

1 Open up the apps tab
2. Click on the Govee Integration V2 App listed on this tab
3 Scroll to the bottom and click on remove as in the second image below.

Once that is done the Uninstall should work. This is more of a HPM function then Govee Integration function.

Thanks @mavrrick58,

Your assistance has been invaluable. After installing all the related LED light drivers and setting up my deck lights in the app, the device is now fully operational with all features working.

Next, I need to learn how to formulate colours, find and load scenes, and determine the Set Effect numbers. First, though, I believe I need a general understanding of how to use the two sets of LED strips I purchased. If you have any suggested reading or YouTube videos that could enlighten me, please share.

Again thank you again for all your help.

The color picker is available when using the Set Color button on the devices. Just click on the color bar underneath the map value to allow you a point and click way to change it.


If you scroll down to the State Variables section of the driver you will see something like what is below. There should be a list of scenes there and the numbers associated as shown. Then all you need to do is use that number in the Set Effect command and the scene will be set.

Unfortunately, I do not. I don't really do much of the advanced stuff with the strips from a Govee perspective.

Thank you for the information; it's very helpful.

I have just published a small update to the Integration app itself.

This update just provides a way to backup DIY Scenes to a flat file for later recovery if desired. This file is stored on the hub and can be found in the hub File manager.

You can backup or restore your DIY's buy using the correct save or restore Buttons under the Scene management menu.

The file is called GoveeLanDIYScenes.json in the file manager. This should help users that have allot of DIY Scenes so you can protect them going forward and not worry about loosing them.


Thank you!

1 Like