Google Home unable to Connect to Hubitat

Google Home is unable to reach Hubitat during the integration process. In the Google Home app, after choosing which hub you want to access I get a “The parameter “state” must be set in the query string” message and I am unable to proceed with the integration process.

I just stumbled onto a potential workaround for this issue. Try the following if you’re having the same issue:

  1. Log in to Hubitat admin.
  2. Click Apps>Google Home
  3. Click “Done”
  4. Go to Google Home App
  5. Add/link Hubitat.
  6. Log-in and voila!

After trying everything mentioned, I still get the same error and never get to choose devices. Is there anything new on this issue?

I am running version, but noticed that since this problem started, whenever I check to see if there's a firmware update, it just gets stuck checking forever.

Also, I just downloaded the Android app and when I tried to login it says "Please wait..." forever. Never logs in. Perhaps the Hubitat server is down?

The workaround I described above worked for me. I’m sorry you’re having issues but it’s definitely a problem.

This sounds like your hub is struggling to stay connected to the Hubitat Cloud server. Tagging @support_team from Hubitat, as they may be able to assist. I know a common cause of an issue like this is having the Hub's network configuration in a state that does not work well with one's network hardware. Try using AUTO for Duplex, instead of FULL. Try using DHCP instead of a static IP address.

1 Like

Does the error you see, say: the parameter "state" must....?

Asking the obvious, but do you have any devices connected directly to Hubitat hub? If so, are they compatible with Google Home Integration?

the parameter " state " must be set in query string

After everything was up and running and I could make changes to the settings, I added two (2) ZigBee Door Contact Switches, which work in Hubitat. I don't believe they're compatible with Google Home, which is part of the reason for having the Hubitat. I then was trying to link my Hubitat Account to Google Home when the message appeared.

I just tried it again now and after I select the hub it sits there for a few seconds and then gives me that error. I get to step 6, but never to step 7.

What is a contact switch? Mind sharing the make/model? The part where it hangs, it does sound like your hub isn't connected to the cloud, which is required to integrate Google Home. But depending on your 2 devices, you may not be able to add the integration.

In any case, if you could send me a private message with your hubId or MAC address I can check to see if your hub is connected to the cloud and will go from there.

I have two (2) CentraLite 3-Series Micro Door Switches. These are also in the Hubitat as Generic ZigBee Contact Sensor.

1 Like

Yup, those are not compatible. But see my updated post above.

I checked your hub and is connected to the cloud. Once you add at least one of the following: switches, dimmers, thermostats, RGB, RGBW and ColorTemperature bulbs; then you should be able to enable Google Assistant voice control of your Hubitat connected devices.

If you are looking to add new devices to your Hubitat hub, check out the following document for devices that have been tested by our engineers: List of Compatible Devices - Hubitat Documentation

I just stumbled across another cause for the dreaded “The parameter state must be set in the query string” Issue.

A few days ago I installed a new router. It changed the Hubitat's previously static IP address to a dynamically assigned address (DHCP). So I set the router to give it a static IP and changed the Hubitat's network settings to use a static IP address as well.

Suddenly Google Assistant wasn't talking to the Hubitat. I tried reauthorizing Google Home to Hubitat and started getting the "parameter state must be..." error.
After wasting hours trying different things, I logged into and noticed that it could not find the hub (even though I could get to it from the static IP address). Using Advanced Discovery, I was able to find the hub by MAC address, but the IP address showed as the DHCP address it had previously assigned.

In other words; The Hubitat thought its IP address was different from what it actually was.

The fix was simple: I changed the Hubitat's network settings back to DHCP briefly, and then changed it right back to Static IP. As soon as I did that, doing the reauthorization in Google Home worked perfectly.

1 Like

The current best practice is to leave Hubitat’s network configure as DHCP. Use the router to reserve an IP address for the Hubitat hub.

The issue with setting a static IP on the hub itself is that it has often resulted in problems being able to connect to the Hubitat cloud server. IIRC, this is caused by issues with configuring the DNS settings. This, the DHCP option has been much more robust.

1 Like

Recently my Google home connection to Hubitat has been lost. All devices previously connected are viewed in the Google home app as offline. “Something went wrong cannot find Hubitat “

I can easily reconnect devices following the steps of gaining a link to Hubitat from Google home. Connection reports successful. Then view all previously offline devices as online. When I give a voice command to ie. Turn on a light from assistant, I get a consistent error message again “Something went wrong cannot find Hubitat. “ All devices go offline again.

I am running three Hubitats all mesh linked. Many many devices. Lights are all Hue bridged with CoCo Hue.

I use one of the Hubitat hubs to connect solely to Google Home.

I did several days ago have a cloud backup failure that I thought was the issue but since resolving that the Google Home connection issue persists.

Most recent logs

Thank you in advance for assistance.

I woke up to a similar issue this morning. When I asked Google to turn on a thermostat, it reported that it couldn't connect. I've tried a bunch of the steps listed to trouble shoot this (update, restart with database rebuild, reboot network, reboot phone, delete the most recently added device, remove hubitat authentication on my google account) and throughout I've gotten a variety of failures.

As of now, I can connect and authorized my habitat, but Google claims there are no supported devices. Which, historically I've had 20 or so.

The only error in the log entry appears to relate to the time I had removed the authorization to connect with Google, and it's no longer coming in.

I'm baffled.

Ok, so I tried the connection again to get some details.

When I add the Hubitat Service in Google Home, I can enter my Hubitat credentials, but then I get this:

Then I get dumped out. I try again, and I'm prompted to Hubitat from the list and the correct one is there. But, once that happens, I get this:

So, I finally spent some more time with this.

I removed the Google Home integration app from Hubitat, rebooted it with rebuilding the database checked, removed the Hubitat access from my Google account Security, removed the Works With Google assistant integration, and cleared cache/data on the Google Home app. And it now works. I'm not sure if it's any one thing, or all of them.

But I'm back, baby /Bender.