Google Home: "Sorry, I couldnt reach the Hubitat........", under V2.3.4.122

I was one of those unfortunates that had unexplained CPU "Severe Load" problems when I upgraded to v4.115 or above and ended up rrestoring down to 3.140. Yesterday morning, when I noticed that 4.122 was available I decided to give that a try. Upgrade worked fine, no issues with CPU and then later that evening at bedtime i told Google Home, "Hey Google, Goodnight" to which it responded the above. This morning when I said, "Hey Google, Good Morning" I got the same response, Both the "Goodnight" and "Good Morning" are Google Home Routines.

I tried to turnoff/on individual Hubitat devices with "Hey Google, turn on/off...." Same response from Google.

I opened up my Google Home app and ran the "Good Morning" routine manually. It worked and so did the "Good Night" routine. Manually turning on/off any Hubitat device with the Google app worked fine.

I rebooted all my Google hubs as well as the Hubitat hub. No go, same error when I tried the"Hey Google..." voice command.

I decided to roll back to the Hubitat version That did the trick. Google Home is once again responding to my voice commands.

No time today but tomorrow AM I plan to upgrade again and see if this problem comes back.

I was having the same issue last night. Google home could not communicate with Hubitat. Telling Google home to "Sync Devices" resulted in having trouble communicating with Hubitat. Hubitat devices in Google Home were showing as Off Line. I rebooted my Google Homes, restarted my Hubitat, restarted my router, removed and re-added Hubitat from Google Home Linked Services - problems persisted. At about 3am, things started to work intermittantly. This morning (so far) things seem to be back to normal. I don't think the problem was on our end.

Unfortunately, at 7AM EST I was still getting the same error. Only after rolling back to .140 did the problem go away. Coincidence?

Maybe. As I said, it was intermittent. Sometimes it worked, and then it just stopped again. Was still having issues. Now this morning all seems normal again, and I didn't roll back anything. Maybe try upgrading and see what happens.

1 Like

That's the plan. Gonna wait a bit to make sure that I dont (eventually) have issues with .140

There were no recent changes to Google Home app. I'd wager that a reboot did the trick, not rolling back the version.

I rebooted twice before the roll back. Didnt make any diff. That said, I havent ruled out the fact that the it working after the roll back was a coincidence and the problem lay with Google its self. I know that the voice command called a routine that executed non-hubitat commands and they worked. Why manually executing the same routine via the app worked completely without error is a puzzle to me. Like I said above, I will upgrade again tomorrow and see what happens.

:laughing:Stay tune

1 Like

Bad News!!!!
Version used is irrelevant. I believe now that Google Home working again under .140 was a coincidence and that I didnt wait/test long enough.

This is what I tried this morning:

Upgraded back to
Google worked fine for about 1 - 2 hours
After that I tried "Hey Google, Good Morning"
"Sorry, I couldnt reach Hubitat"
"Sorry it looks like Hubitat is Unavailable right now"

Tried the above 3 times. Errors with the first two attemps. The 3rd time was a charm.
Anyway 2 out of 3 isnt good. So....

Downgraded to .140.
Same errors as with v4.122

Rebooting made no difference. Sometimes Google Home worked but mostly It said Hubitat was unavailable. Very strange concidering the Google Home app works fine.

Everything was intermittently offline yesterday for me, but today seems better. I suspect it was Google-side but it's useful to know I wasn't the only one experiencing issues to rule out gremlins on my setup.

1 Like

Googling the error this problem is not uncommon. Same issues, Voice command fails but app works. No solution to be found (yet)

Been solid again all day today. Agree, seemed to be Google-side issue. I added devices, added routines, voice controlled everything without any issues this evening.

1 Like

Everything was working for me last night and this morning. Curious though, those who reported intermittent problems was that just with voice control? Did using the app work without issue?

It's not working for me on Dec 25. I am running I rebooted too.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.