Google Home Says Virtual Switches Not Available - but works!

Random question and I'm not sure if its a HE issue or a GH issue.

Having trouble with my Magic Home RGB lights. I created a virual switch using the driver and it works fine testing on/off within HE and in my Simple Lighting. It added to Google Home fine as well, and works in the routines that I've created.

But when I try to control it via voice, it turns on/off, but says "The light isn't available, you might want to try setting it up again."

Is there some kind of reporting delay / device sleep setting that makes Google think the device is offline, even though it is turning on?

Its just annoying because Google is still telling me each step of the routine and reporting on it. I think that is being fixed by Google, so this may become a non-issue. But since I'm always inclined to make everything work "perfectly" I figured I'd ask.


You are using a REAL driver with a VIRTUAL device. The device isn't reporting back to confirm that the changes were made. This is what I would expect to happen. I'm surprised it reported correctly using it from RM or Simple Lighting. Are the attributes actually updating on the edit device page?

I'll check on what is being reported back. But last week the same set up worked fine. Or at least I thought it did.

I'm struggling with the Magic Home linking to my Google Home app. I'm pretty sure it is linked because when I "sync devices" GH says "syncing 5" but there are only 4 listed. The error just started happening, so I unlinked the magic home service from GH and created a virtual switch to add back through HE.

I'm having general GH issues overall. I have a bunch of phantom speaker and light groups that I can't seem to get rid of either, amd wondering if it's all related somehow.

I think I created duplicate devices with the magic home - one from the direct GH app and a second virtual one in HE. I probably didn't realize which one 2as working and which wasn't.

I was following the instructions from the driver release.


Okay... Well, I wouldn't consider that a virtual device anymore... Virtual devices don't connect to anything in the read world. That's why they're virtual. As soon as you connect HE to the device by entering the IP it became a lan device. So, I apologize for the confusion there.

Are HE and the MH decide on the same subnet of your network?

The MH driver implements the standard Hubitat implementation. I'll check and see if there's anything special that I should be doing (there shouldn't be). I've been using them reliably with Alexa since day 1—and I've heard Google does have a bunch of implementation issues across the board, with some spotty services.

That being said, I'll add it to my list of things to test. I'll also ask if any others are having this issue.

Thanks Adam.

And for the record, I doubt there's anything for you to do (but what do I know?). Last week this worked fine. This week, Google is being a PITA.

1 Like

If you wanted a good control test, you could make some new (actual) virtual devices and test those with Google.

Devices > Add Virtual Device > Virtual [RGB Bulb/Switch/Dimmer/Etc...]

Those should fire every time—I often use them to debug interface issues :slight_smile: