Google Home regularly losing Hubitat


I am very new to Hubitat. So far I have been pretty impressed but my Google home keeps losing the Hubitat. It works fine most of the time but multiple times a day voice commands will be met with I'm sorry but I could not reach the Hubitat. Its super frustrating.

I have tried rebooting the hub, updating the firmware and I have tried reconnecting my account in Google Home. Any other ideas?

^^Bump^^ Still infuriated with this issue if anyone can help

First of all welcome to Hubitat! I believe the reason you haven't got a response is because it doesn't appear to be an issue with Hubitat. You might want to take a look at this troubleshooting video to see if the issue could be related to your Google device.

Thanks a million. I've just gone through all of that but I am pretty sure my issue is something else.
Some more context about my setup.

I have a fibre ISP connection connected to a Unifi Security Gateway and a 24 port Unifi switch. The Hubitat is plugged via ethernet into the switch in a cupboard in the hall.

There is an access point directly above the Google Home. The Up and Down speeds are both circa 100Mbps. Google Home works perfectly for everything except Hubitat.

I have given the Hubitat a static IP in my Unifi Controller and it always appears as the same IP address in the Hubitat.

Some of the time Hubitat works perfectly. Most of the time Google said it can't find the Hubitat.

I have unlinked completely and relinked using my wife's account which is also an admin on my hub. I then relinked using my account. The same issue persists

{SOLVED) Turn out my network was double natted and that was causing my issues. I managed to remove my ISP router from my set up and everything was resolved. Hope this helps someone else in the future.


Thank you for sharing the solution!


You using vlans?

Hi, I am not sure how this double NAT can be a problem, as long as the 2 devices are cloud-connected (as opposed to NAT port-forwarding).
E.g: I am having the same issues with a HE-GH integration, in a single NAT setup!